summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-03-10 11:57:15 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-03-10 11:57:37 +0100
commit7683b4595233fb87df180054e1af3babba022eb5 (patch)
treeea9f2fc2746aab73de31cb56a3f983af0da67550 /x11-plugins
parentx11-plugins/wmxkb: fix implicit function declarations in configure (diff)
downloadgentoo-7683b4595233fb87df180054e1af3babba022eb5.tar.gz
gentoo-7683b4595233fb87df180054e1af3babba022eb5.tar.bz2
gentoo-7683b4595233fb87df180054e1af3babba022eb5.zip
x11-plugins/wmwork: fix implicit function declarations in configure
Closes: https://bugs.gentoo.org/899064 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmwork/wmwork-0.2.5-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/x11-plugins/wmwork/wmwork-0.2.5-r1.ebuild b/x11-plugins/wmwork/wmwork-0.2.5-r1.ebuild
index c5dac0be2f93..6a51842e1cda 100644
--- a/x11-plugins/wmwork/wmwork-0.2.5-r1.ebuild
+++ b/x11-plugins/wmwork/wmwork-0.2.5-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="a dockapp that lets you easily track time spent on different projects"
HOMEPAGE="https://www.dockapps.net/wmwork"
SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
@@ -21,3 +23,8 @@ S="${WORKDIR}/${P}/src"
DOCS=( ../{CHANGES,README} )
PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}