summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-12-20 22:13:58 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-12-20 22:14:16 +0100
commit842ae0293d658d623527ccdadac7a4d25496a3d3 (patch)
treefc678e7332f06a4de5e39b5d09c5f09ad9839930 /x11-plugins
parentpackage.mask: Fix bug number (diff)
downloadgentoo-842ae0293d658d623527ccdadac7a4d25496a3d3.tar.gz
gentoo-842ae0293d658d623527ccdadac7a4d25496a3d3.tar.bz2
gentoo-842ae0293d658d623527ccdadac7a4d25496a3d3.zip
x11-plugins/wmmaiload: multiple build fixes
Fix build with -fno-common Set CPP Use patch for SSL fix, bump EAPI Closes: https://bugs.gentoo.org/708542 Closes: https://bugs.gentoo.org/760588 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmaiload/files/wmmaiload-2.3.0-fno-common.patch113
-rw-r--r--x11-plugins/wmmaiload/files/wmmaiload-2.3.0-ssl.patch24
-rw-r--r--x11-plugins/wmmaiload/wmmaiload-2.3.0-r2.ebuild46
3 files changed, 183 insertions, 0 deletions
diff --git a/x11-plugins/wmmaiload/files/wmmaiload-2.3.0-fno-common.patch b/x11-plugins/wmmaiload/files/wmmaiload-2.3.0-fno-common.patch
new file mode 100644
index 000000000000..f4c0eb9763b6
--- /dev/null
+++ b/x11-plugins/wmmaiload/files/wmmaiload-2.3.0-fno-common.patch
@@ -0,0 +1,113 @@
+diff -Naur wmmaiload-2.3.0.orig/wmmaiload-config/main.c wmmaiload-2.3.0/wmmaiload-config/main.c
+--- wmmaiload-2.3.0.orig/wmmaiload-config/main.c 2005-07-13 21:51:28.000000000 +0200
++++ wmmaiload-2.3.0/wmmaiload-config/main.c 2020-12-20 22:04:03.170530520 +0100
+@@ -11,6 +11,18 @@
+ #include "mainwindow.h"
+ #include "actions.h"
+
++int backlight;
++int update_interval;
++int boxnum;
++int check_delay;
++int switch_authorized;
++int run_once;
++int test_size;
++char *config_file;
++char *light_color;
++char *command;
++char *notif_cmd;
++MailBox *mboxes;
+
+ void Usage ()
+ {
+diff -Naur wmmaiload-2.3.0.orig/wmmaiload-config/mainwindow.c wmmaiload-2.3.0/wmmaiload-config/mainwindow.c
+--- wmmaiload-2.3.0.orig/wmmaiload-config/mainwindow.c 2009-02-23 03:58:00.000000000 +0100
++++ wmmaiload-2.3.0/wmmaiload-config/mainwindow.c 2020-12-20 22:05:14.978622375 +0100
+@@ -9,6 +9,19 @@
+ #include "mainwindow.h"
+ #include "actions.h"
+
++GtkWidget *application;
++GtkWidget *filelist;
++GtkWidget *wid_backlight;
++GtkWidget *wid_blink;
++GtkWidget *wid_interval;
++GtkWidget *wid_checkdelay;
++GtkWidget *wid_color;
++GtkWidget *wid_command;
++GtkWidget *wid_notify;
++GtkWidget *wid_runonce;
++GtkWidget *wid_testsize;
++
++int selected_row;
+
+ static GtkWidget *b_edit;
+ static GtkWidget *b_set;
+diff -Naur wmmaiload-2.3.0.orig/wmmaiload-config/mainwindow.h wmmaiload-2.3.0/wmmaiload-config/mainwindow.h
+--- wmmaiload-2.3.0.orig/wmmaiload-config/mainwindow.h 2005-07-07 20:54:17.000000000 +0200
++++ wmmaiload-2.3.0/wmmaiload-config/mainwindow.h 2020-12-20 22:05:14.978622375 +0100
+@@ -7,19 +7,19 @@
+
+ #include <gtk/gtk.h>
+
+-GtkWidget *application;
+-GtkWidget *filelist;
+-GtkWidget *wid_backlight;
+-GtkWidget *wid_blink;
+-GtkWidget *wid_interval;
+-GtkWidget *wid_checkdelay;
+-GtkWidget *wid_color;
+-GtkWidget *wid_command;
+-GtkWidget *wid_notify;
+-GtkWidget *wid_runonce;
+-GtkWidget *wid_testsize;
++extern GtkWidget *application;
++extern GtkWidget *filelist;
++extern GtkWidget *wid_backlight;
++extern GtkWidget *wid_blink;
++extern GtkWidget *wid_interval;
++extern GtkWidget *wid_checkdelay;
++extern GtkWidget *wid_color;
++extern GtkWidget *wid_command;
++extern GtkWidget *wid_notify;
++extern GtkWidget *wid_runonce;
++extern GtkWidget *wid_testsize;
+
+-int selected_row;
++extern int selected_row;
+
+ gint list_unsel_cb (GtkCList *clist,
+ gint row,
+diff -Naur wmmaiload-2.3.0.orig/wmmaiload-config/variables.h wmmaiload-2.3.0/wmmaiload-config/variables.h
+--- wmmaiload-2.3.0.orig/wmmaiload-config/variables.h 2005-07-07 20:54:17.000000000 +0200
++++ wmmaiload-2.3.0/wmmaiload-config/variables.h 2020-12-20 22:04:03.170530520 +0100
+@@ -7,17 +7,17 @@
+
+ #include "defines.h"
+
+-int backlight;
+-int update_interval;
+-int boxnum;
+-int check_delay;
+-int switch_authorized;
+-int run_once;
+-int test_size;
+-char *config_file;
+-char *light_color;
+-char *command;
+-char *notif_cmd;
+-MailBox *mboxes;
++extern int backlight;
++extern int update_interval;
++extern int boxnum;
++extern int check_delay;
++extern int switch_authorized;
++extern int run_once;
++extern int test_size;
++extern char *config_file;
++extern char *light_color;
++extern char *command;
++extern char *notif_cmd;
++extern MailBox *mboxes;
+
+ #endif
diff --git a/x11-plugins/wmmaiload/files/wmmaiload-2.3.0-ssl.patch b/x11-plugins/wmmaiload/files/wmmaiload-2.3.0-ssl.patch
new file mode 100644
index 000000000000..812563486256
--- /dev/null
+++ b/x11-plugins/wmmaiload/files/wmmaiload-2.3.0-ssl.patch
@@ -0,0 +1,24 @@
+diff -Naur wmmaiload-2.3.0.orig/wmmaiload/Init.make wmmaiload-2.3.0/wmmaiload/Init.make
+--- wmmaiload-2.3.0.orig/wmmaiload/Init.make 2005-08-28 21:14:57.000000000 +0200
++++ wmmaiload-2.3.0/wmmaiload/Init.make 2020-12-20 22:10:24.487996211 +0100
+@@ -45,7 +45,7 @@
+ # SPECIFIC INFORMATIONS :
+ #
+
+-LIB_SSL = $(shell grep -q '^OPTIONS.*HAVE_SSL' ../Config.make && echo '-lssl')
++LIB_SSL = $(shell grep -q '^OPTIONS.*HAVE_SSL' ../Config.make && echo '-lssl -lcrypto')
+ LIB_THREADS = $(shell grep -q '^OPTIONS.*HAVE_THREADS' ../Config.make && echo '-lpthread')
+
+ CROSS_COMPILE =
+diff -Naur wmmaiload-2.3.0.orig/wmmaiload/ssl.c wmmaiload-2.3.0/wmmaiload/ssl.c
+--- wmmaiload-2.3.0.orig/wmmaiload/ssl.c 2005-07-30 15:52:55.000000000 +0200
++++ wmmaiload-2.3.0/wmmaiload/ssl.c 2020-12-20 22:10:30.327001632 +0100
+@@ -39,7 +39,7 @@
+
+ OpenSSL_add_all_algorithms();
+
+- method = SSLv2_client_method();
++ method = SSLv23_client_method();
+ ctx = SSL_CTX_new(method);
+ return ctx;
+ }
diff --git a/x11-plugins/wmmaiload/wmmaiload-2.3.0-r2.ebuild b/x11-plugins/wmmaiload/wmmaiload-2.3.0-r2.ebuild
new file mode 100644
index 000000000000..79edd2c03eb7
--- /dev/null
+++ b/x11-plugins/wmmaiload/wmmaiload-2.3.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="dockapp that monitors one or more mailboxes"
+HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
+SRC_URI="http://tnemeth.free.fr/projets/programmes/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.1-checkthread.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-ssl.patch
+)
+
+src_configure() {
+ # The ./configure script is not autoconf based, therefore don't use econf:
+ ./configure -p /usr || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CPP="$(tc-getCPP)" \
+ CFLAGS="${CFLAGS}" \
+ DEBUG_LDFLAGS="" \
+ LDFLAGS="${LDFLAGS}" \
+ DEBUG_CFLAGS=""
+}
+
+src_install() {
+ dobin ${PN}/${PN} ${PN}-config/${PN}-config
+ doman doc/*.1
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO doc/sample.${PN}rc
+}