summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-01-01 22:53:28 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2021-01-01 22:53:39 +0100
commit87cc63f928f9542b8d114f18e32c8df1377515dd (patch)
treef9f17b1009fa0f94f964af6a41cf4aebbea330e7 /x11-plugins
parentpackage.mask: Unmask Perl 5.32 (diff)
downloadgentoo-87cc63f928f9542b8d114f18e32c8df1377515dd.tar.gz
gentoo-87cc63f928f9542b8d114f18e32c8df1377515dd.tar.bz2
gentoo-87cc63f928f9542b8d114f18e32c8df1377515dd.zip
x11-plugins/wminet: fix build with -fno-common
Closes: https://bugs.gentoo.org/707296 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wminet/files/wminet-3.0.0-fno-common.patch23
-rw-r--r--x11-plugins/wminet/wminet-3.0.0-r2.ebuild6
2 files changed, 27 insertions, 2 deletions
diff --git a/x11-plugins/wminet/files/wminet-3.0.0-fno-common.patch b/x11-plugins/wminet/files/wminet-3.0.0-fno-common.patch
new file mode 100644
index 000000000000..606dada2fb30
--- /dev/null
+++ b/x11-plugins/wminet/files/wminet-3.0.0-fno-common.patch
@@ -0,0 +1,23 @@
+diff -Naur wminet-3.0.0.orig/src/wmgeneral.h wminet-3.0.0/src/wmgeneral.h
+--- wminet-3.0.0.orig/src/wmgeneral.h 2001-12-02 19:03:14.000000000 +0100
++++ wminet-3.0.0/src/wmgeneral.h 2021-01-01 22:51:46.875206930 +0100
+@@ -15,7 +15,7 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
+diff -Naur wminet-3.0.0.orig/src/wminet.c wminet-3.0.0/src/wminet.c
+--- wminet-3.0.0.orig/src/wminet.c 2001-11-24 12:03:32.000000000 +0100
++++ wminet-3.0.0/src/wminet.c 2021-01-01 22:51:41.493202753 +0100
+@@ -78,6 +78,7 @@
+ /* Globals */
+ /******************************************/
+
++Display *display;
+ char mask[MASK_WIDTH * MASK_HEIGHT];
+ int monitor_tcp = 0;
+ int monitor_udp = 0;
diff --git a/x11-plugins/wminet/wminet-3.0.0-r2.ebuild b/x11-plugins/wminet/wminet-3.0.0-r2.ebuild
index e4fc9ee0d5ad..55bb40840be9 100644
--- a/x11-plugins/wminet/wminet-3.0.0-r2.ebuild
+++ b/x11-plugins/wminet/wminet-3.0.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,9 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-PATCHES=( "${FILESDIR}"/${P}-list.patch )
+PATCHES=( "${FILESDIR}"/${P}-list.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ )
DOCS=( AUTHORS ChangeLog NEWS README wminetrc )