summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-09 12:07:45 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-09 12:07:45 +0200
commit9664f1124ece562ef22a9c94620741447a9d649d (patch)
treeaa32d96dd83b24af489a15cb81b6a3f188fc64f6 /x11-plugins
parentnet-print/cups-filters: Bump to version 1.25.1 (diff)
downloadgentoo-9664f1124ece562ef22a9c94620741447a9d649d.tar.gz
gentoo-9664f1124ece562ef22a9c94620741447a9d649d.tar.bz2
gentoo-9664f1124ece562ef22a9c94620741447a9d649d.zip
x11-plugins/enigmail: Bump to version 2.0.12
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/enigmail/Manifest1
-rw-r--r--x11-plugins/enigmail/enigmail-2.0.12.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/x11-plugins/enigmail/Manifest b/x11-plugins/enigmail/Manifest
index 9af0c850917b..438f8a2036c8 100644
--- a/x11-plugins/enigmail/Manifest
+++ b/x11-plugins/enigmail/Manifest
@@ -1,3 +1,4 @@
DIST enigmail-2.0.10.tar.gz 2608628 BLAKE2B da35fb3b79b8d4a8895ccc431d6990beab328db3dae9da17dab681f11cdd80af43f30ee52ea0d387820dde82256afa394525cd5d20471b6db4493060ff34fa96 SHA512 cca49c768b330767e23ede2258bcaf7693f37a81e651a7c8a7fbb9c0dad0d4d6383582a45b608cbfc234fe33e053c291ad9df01589214c58678da621235c7e33
DIST enigmail-2.0.11.tar.gz 2613428 BLAKE2B a32c3dd49364973133f0bc9729ea80857a886cbd1ced065f32e6141e1e18602fa904a53a836496dd53cf7986c6f367b4aba57b8a4177c1aa1ae24668f18f74b4 SHA512 9e4836a8ce3310fef6398be538ef8def70413112d4141c13b8abdbdc2e1a7b75ed080c261cdb018f873a50a4c591b06d722dc7986474678c4a9072f7e3b729cf
+DIST enigmail-2.0.12.tar.gz 2614589 BLAKE2B 3db6f595c14e02cfdc71bebc763d05926dc6e0abf4668d132fd0ce43204e681de5fce45db752c4f49b231bd7e217b75c0f23d4a7e204fa9a3a51f1c8097fb63d SHA512 f9f4f1ed4c7244280be2fade0ccb2f4b5e7075dd60f53953478ffb84012e687b7ac7bad489c0b0cb2d8937916c783fe9e1841174bf1e5bdb9ab8cb58b415db74
DIST enigmail-2.0.8.tar.gz 2525691 BLAKE2B cd69efe72b661bb103837c987937e1cee64a5888795bda7126c59cf99a39c0245f505cdfd6538d54cec5dc3fc95c64bbeca3aebc4b0823249be4c0465d4d68a1 SHA512 9d2e95c2eae6ca22897eb8b2961964d96fd633e7d33a8c0c04a29b4cbc8585777598578abfb0484b96827ca165fe9c8b873e5e7f7cb3ba8cd0779ddc4f10e305
diff --git a/x11-plugins/enigmail/enigmail-2.0.12.ebuild b/x11-plugins/enigmail/enigmail-2.0.12.ebuild
new file mode 100644
index 000000000000..3441befecb08
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-2.0.12.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="Mozilla extension to provide GPG support in mail clients"
+HOMEPAGE="https://www.enigmail.net/"
+
+SLOT="0"
+LICENSE="MPL-2.0 GPL-3"
+IUSE=""
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.code.sf.net/p/enigmail/source"
+ S="${WORKDIR}/${P}"
+else
+ if [[ ${PV} = *_beta* ]] ; then
+ SRC_URI="https://www.enigmail.net/download/beta/${P/_/-}.tar.gz"
+ else
+ SRC_URI="https://www.enigmail.net/download/source/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+ fi
+ S="${WORKDIR}/${PN}"
+fi
+
+RDEPEND="|| (
+ ( >=app-crypt/gnupg-2.0
+ || (
+ app-crypt/pinentry[gtk(-)]
+ app-crypt/pinentry[qt5(-)]
+ )
+ )
+ =app-crypt/gnupg-1.4*
+ )
+ !<mail-client/thunderbird-52.5.0
+ !<www-client/seamonkey-2.49.5.0_p0
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ app-arch/zip
+ dev-lang/perl
+ "
+
+PATCHES=( "${FILESDIR}"/enigmail-no_pEp_auto_download.patch )
+
+src_compile() {
+ emake ipc public ui package lang stdlib
+ emake xpi
+
+}
+
+src_install() {
+ local emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' build/dist/install.rdf)
+ [[ -n ${emid} ]] || die "Could not scrape EM:ID from install.rdf"
+
+ mv build/enigmail*.xpi build/"${emid}.xpi" || die 'Could not rename XPI to match EM:ID'
+
+ # thunderbird
+ insinto "/usr/share/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}"
+ doins build/"${emid}.xpi"
+
+ # seamonkey
+ insinto "/usr/share/mozilla/extensions/{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}"
+ doins build/"${emid}.xpi"
+}
+
+pkg_postinst() {
+ local peimpl=$(eselect --brief --colour=no pinentry show)
+ case "${peimpl}" in
+ *gtk*|*qt*) ;;
+ *) ewarn "The pinentry front-end currently selected is not one supported by thunderbird."
+ ewarn "You may be prompted for your password in an inaccessible shell!!"
+ ewarn "Please use 'eselect pinentry' to select either the gtk or qt front-end"
+ ;;
+ esac
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "Please restart thunderbird and/or seamonkey in order for them to use"
+ elog "the newly installed version of enigmail."
+ fi
+}