summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-18 18:24:46 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-09-19 22:37:28 +0200
commitb7850569301abf47631e4c3e49576d1e7d0e9304 (patch)
tree8716c829f46da28c57582240fff59f3f5206918f /x11-plugins
parentx11-plugins/wmbio: EAPI8 bump, fix LICENSE (diff)
downloadgentoo-b7850569301abf47631e4c3e49576d1e7d0e9304.tar.gz
gentoo-b7850569301abf47631e4c3e49576d1e7d0e9304.tar.bz2
gentoo-b7850569301abf47631e4c3e49576d1e7d0e9304.zip
x11-plugins/wmblob: EAPI8 bump, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmblob/wmblob-1.0.4-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/wmblob/wmblob-1.0.4-r1.ebuild b/x11-plugins/wmblob/wmblob-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..fb0d67e04abb
--- /dev/null
+++ b/x11-plugins/wmblob/wmblob-1.0.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Fancy but useless dockapp with moving blobs"
+HOMEPAGE="https://github.com/bbidulock/wmblob"
+SRC_URI="https://github.com/bbidulock/wmblob/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+BDEPEND="virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README doc/how_it_works"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s|-O2|${CFLAGS}|g" \
+ -e "s|\$x_libraries|/usr/$(get_libdir)|" \
+ configure.ac || die
+
+ eautoreconf
+}