summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-22 01:06:21 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-22 01:06:21 +0200
commitc2582f8b0bf99a83da52965776abf73e502427f9 (patch)
treeceb2eb98db4b0366ea19c67185c4f73bc94f71a3 /x11-plugins
parentwww-apps/phpsysinfo: bump to version 3.3.4 (diff)
downloadgentoo-c2582f8b0bf99a83da52965776abf73e502427f9.tar.gz
gentoo-c2582f8b0bf99a83da52965776abf73e502427f9.tar.bz2
gentoo-c2582f8b0bf99a83da52965776abf73e502427f9.zip
x11-plugins/pidgin-telegram: bump to version 1.4.7
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-telegram/Manifest1
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.4.7.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-telegram/Manifest b/x11-plugins/pidgin-telegram/Manifest
index 7f44531286fd..8ef79638a3aa 100644
--- a/x11-plugins/pidgin-telegram/Manifest
+++ b/x11-plugins/pidgin-telegram/Manifest
@@ -1 +1,2 @@
DIST telegram-purple_1.4.6.orig.tar.gz 497757 BLAKE2B 1f666aaf4ef1913420cf735e3d85e1d91be8a2f07932785d55bc0be37e2cd8cabaf6b0be2b520afafc6636a692086be180d3bd4438215f8b14ae867da9891e18 SHA512 bf3e14a2d1dec7382833011ea891ba5bce81820766b3d6adee582bf0257baadeb7aa7eab7aa6e20adf8dd7728eb653db35b1d8f56bfffe7a92f9bf7506401e6e
+DIST telegram-purple_1.4.7.orig.tar.gz 498573 BLAKE2B 37f741f1e2106db55eaadab70e2bf226609ebd85fa3df28a60b686e207c341f7279ea36ef87137d465b5bedac63e6ec0388714171dd5a594fb28ae02f66bebc4 SHA512 ae3032b33bd2a20b58b2d66c83fbc405f43c38c0e93b00394ad3165b0bc5d5aba02a8e1946872e4bd082894679737fa20f3e1991e9bb16c3c3aba4c7abbbf7d8
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.7.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.7.ebuild
new file mode 100644
index 000000000000..5cb4ffba69c3
--- /dev/null
+++ b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A libpurple protocol plugin that adds support for the Telegram messenger"
+HOMEPAGE="https://github.com/majn/telegram-purple"
+SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/telegram-purple_${PV}.orig.tar.gz"
+S="${WORKDIR}/telegram-purple"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="gcrypt +nls +png +webp"
+
+RDEPEND="
+ net-im/pidgin
+ sys-libs/zlib:=
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ !gcrypt? ( dev-libs/openssl:0= )
+ png? ( media-libs/libpng:0= )
+ webp? ( media-libs/libwebp:= )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS=( "AUTHORS" "CHANGELOG.md" "HACKING.md" "HACKING.BUILD.md" "README.md" )
+
+src_prepare() {
+ default
+
+ # Remove '-Werror' to make it compile
+ find -name 'Makefile*' -exec sed -i -e 's/-Werror //' {} + || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable gcrypt)
+ $(use_enable nls translation)
+ $(use_enable png libpng)
+ $(use_enable webp libwebp)
+ )
+
+ econf "${myeconfargs[@]}"
+}