summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-22 17:35:55 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-08-02 22:12:53 +0200
commitc6aa63b40e285f14caf3246d77d7d67b326127f9 (patch)
tree536a7b84d557e7516a29b06bfca62b0955a10d20 /x11-plugins
parentx11-plugins/wmlife: fix typo, remove redundant PATCHES (diff)
downloadgentoo-c6aa63b40e285f14caf3246d77d7d67b326127f9.tar.gz
gentoo-c6aa63b40e285f14caf3246d77d7d67b326127f9.tar.bz2
gentoo-c6aa63b40e285f14caf3246d77d7d67b326127f9.zip
x11-plugins/wmlife: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmlife/wmlife-1.0.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/wmlife/wmlife-1.0.1-r1.ebuild b/x11-plugins/wmlife/wmlife-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..d3e3ba865bcc
--- /dev/null
+++ b/x11-plugins/wmlife/wmlife-1.0.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="dockapp running Conway's Game of Life (and program launcher)"
+HOMEPAGE="http://www.improbability.net/#wmlife"
+SRC_URI="http://www.improbability.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0.0-stringh.patch
+ "${FILESDIR}"/${P}-configure.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-session
+}