summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-09 13:32:40 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-09 13:32:40 +0100
commitd4de68e1800d90aa102de48a1a749362f3141fbc (patch)
treecab28bd96ad012417857ba447dd46f3e8bf3d8b3 /x11-plugins
parentnet-misc/wget: Bump to version 1.21.1 (diff)
downloadgentoo-d4de68e1800d90aa102de48a1a749362f3141fbc.tar.gz
gentoo-d4de68e1800d90aa102de48a1a749362f3141fbc.tar.bz2
gentoo-d4de68e1800d90aa102de48a1a749362f3141fbc.zip
x11-plugins/pidgin-telegram: bump to version 1.4.6
Closes: https://bugs.gentoo.org/764551 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-telegram/Manifest1
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-telegram/Manifest b/x11-plugins/pidgin-telegram/Manifest
index ce6f0478c52f..a00c5606393e 100644
--- a/x11-plugins/pidgin-telegram/Manifest
+++ b/x11-plugins/pidgin-telegram/Manifest
@@ -1 +1,2 @@
DIST telegram-purple_1.4.4.orig.tar.gz 495386 BLAKE2B 7ecac3a334f88f3d9c0367c5910d3de03b1e6749f18628a58f90c0ae3602dd04d0a1bec79b1016af236375bfe3eb7d4c40437c31fbbee0e9648e5425e40bb43d SHA512 9907da48b978294749f0697313cc7dbf26358535d6528190d8b61cdce5e478af8e756528a212af806025eb75b7f7ec90054ee763eea327f101ef469d0f4fd43e
+DIST telegram-purple_1.4.6.orig.tar.gz 497757 BLAKE2B 1f666aaf4ef1913420cf735e3d85e1d91be8a2f07932785d55bc0be37e2cd8cabaf6b0be2b520afafc6636a692086be180d3bd4438215f8b14ae867da9891e18 SHA512 bf3e14a2d1dec7382833011ea891ba5bce81820766b3d6adee582bf0257baadeb7aa7eab7aa6e20adf8dd7728eb653db35b1d8f56bfffe7a92f9bf7506401e6e
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild
new file mode 100644
index 000000000000..06014ab6c69c
--- /dev/null
+++ b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A libpurple protocol plugin that adds support for the Telegram messenger"
+HOMEPAGE="https://github.com/majn/telegram-purple"
+SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/telegram-purple_${PV}.orig.tar.gz"
+S="${WORKDIR}/telegram-purple"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="gcrypt libressl +nls +png +webp"
+
+RDEPEND="
+ net-im/pidgin
+ sys-libs/zlib:=
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ !gcrypt? (
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ )
+ png? ( media-libs/libpng:0= )
+ webp? ( media-libs/libwebp:= )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS=( "AUTHORS" "CHANGELOG.md" "HACKING.md" "HACKING.BUILD.md" "README.md" )
+
+src_prepare() {
+ default
+
+ # Remove '-Werror' to make it compile
+ find -name 'Makefile*' -exec sed -i -e 's/-Werror //' {} + || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable gcrypt)
+ $(use_enable nls translation)
+ $(use_enable png libpng)
+ $(use_enable webp libwebp)
+ )
+
+ econf "${myeconfargs[@]}"
+}