summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-03 04:43:34 +0000
committerSam James <sam@gentoo.org>2023-02-03 05:07:43 +0000
commitd6ec561b5081eb4cc13705be8f422f84fa53f17c (patch)
tree79340b4bfc8c1224832b2a82015f0322911de629 /x11-plugins
parentmedia-plugins/gkrellmpc: scrub patch (diff)
downloadgentoo-d6ec561b5081eb4cc13705be8f422f84fa53f17c.tar.gz
gentoo-d6ec561b5081eb4cc13705be8f422f84fa53f17c.tar.bz2
gentoo-d6ec561b5081eb4cc13705be8f422f84fa53f17c.zip
x11-plugins/bfm: EAPI 8
Bug: https://bugs.gentoo.org/892251 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/bfm/bfm-0.6.4-r4.ebuild (renamed from x11-plugins/bfm/bfm-0.6.4-r3.ebuild)25
1 files changed, 15 insertions, 10 deletions
diff --git a/x11-plugins/bfm/bfm-0.6.4-r3.ebuild b/x11-plugins/bfm/bfm-0.6.4-r4.ebuild
index d93d9ff88a99..1fd42525ff60 100644
--- a/x11-plugins/bfm/bfm-0.6.4-r3.ebuild
+++ b/x11-plugins/bfm/bfm-0.6.4-r4.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit toolchain-funcs
-DESCRIPTION="a dockapp and gkrellm plug-in combining timecop's bubblemon and wmfishtime"
+DESCRIPTION="Dockapp and gkrellm plug-in combining timecop's bubblemon and wmfishtime"
HOMEPAGE="https://github.com/JNRowe-retired/bfm"
SRC_URI="https://github.com/JNRowe-retired/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -13,14 +14,18 @@ SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="gkrellm"
-RDEPEND="x11-libs/gtk+:2
+RDEPEND="
+ gkrellm? ( >=app-admin/gkrellm-2[X] )
+ x11-libs/gtk+:2
x11-libs/libX11
- x11-libs/libXext"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- gkrellm? ( >=app-admin/gkrellm-2[X] )"
-
-PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+ x11-libs/libXext
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+)
src_compile() {
emake CC="$(tc-getCC)" GENTOO_LDFLAGS="${LDFLAGS}"