summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-01-03 00:20:34 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2021-01-03 00:32:18 +0100
commite69b37d280ac621a146d272f811907c2062bcbce (patch)
treeff67dc668dfaf0be703c84c95506c351f0c336d6 /x11-plugins
parentdev-python/pillow: Bump to 8.1.0 (diff)
downloadgentoo-e69b37d280ac621a146d272f811907c2062bcbce.tar.gz
gentoo-e69b37d280ac621a146d272f811907c2062bcbce.tar.bz2
gentoo-e69b37d280ac621a146d272f811907c2062bcbce.zip
x11-plugins/wmpasman: do not call ar directly
Closes: https://bugs.gentoo.org/759760 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmpasman/files/wmpasman-2.2-ar.patch11
-rw-r--r--x11-plugins/wmpasman/wmpasman-2.2.ebuild10
2 files changed, 20 insertions, 1 deletions
diff --git a/x11-plugins/wmpasman/files/wmpasman-2.2-ar.patch b/x11-plugins/wmpasman/files/wmpasman-2.2-ar.patch
new file mode 100644
index 000000000000..8244fadd7c5b
--- /dev/null
+++ b/x11-plugins/wmpasman/files/wmpasman-2.2-ar.patch
@@ -0,0 +1,11 @@
+diff -Naur wmpasman-2.2.orig/configure.ac wmpasman-2.2/configure.ac
+--- wmpasman-2.2.orig/configure.ac 2018-12-16 17:39:47.000000000 +0100
++++ wmpasman-2.2/configure.ac 2021-01-03 00:17:27.934691093 +0100
+@@ -9,6 +9,7 @@
+ AC_SUBST(VERSION)
+
+ # Checks for programs.
++AM_PROG_AR
+ AC_PROG_AWK
+ AC_PROG_CC
+ AC_PROG_CC_STDC
diff --git a/x11-plugins/wmpasman/wmpasman-2.2.ebuild b/x11-plugins/wmpasman/wmpasman-2.2.ebuild
index fea3eb770322..04ba57ef0952 100644
--- a/x11-plugins/wmpasman/wmpasman-2.2.ebuild
+++ b/x11-plugins/wmpasman/wmpasman-2.2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
DESCRIPTION="Password storage/retrieval in a dockapp"
HOMEPAGE="https://sourceforge.net/projects/wmpasman/"
@@ -18,3 +19,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS="ChangeLog WARNINGS"
+
+PATCHES=( "${FILESDIR}"/${P}-ar.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}