summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-11 16:31:35 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-11 16:38:01 -0800
commit52dcceed16ebcb4c7f590fcbc8007c752428f6c9 (patch)
tree16843419d034bb376c05967fa7dbf0db035294e9 /x11-terms/alacritty/files
parentdev-lang/php: bump to v7.3.0 RC5 (diff)
downloadgentoo-52dcceed16ebcb4c7f590fcbc8007c752428f6c9.tar.gz
gentoo-52dcceed16ebcb4c7f590fcbc8007c752428f6c9.tar.bz2
gentoo-52dcceed16ebcb4c7f590fcbc8007c752428f6c9.zip
x11-terms/alacritty: version bump to 0.2.2
Patch things up a little to avoid fetching custom windows crates Run tests with less verbosity (does not affect test output) Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'x11-terms/alacritty/files')
-rw-r--r--x11-terms/alacritty/files/alacritty-0.2.2-avoid-fetching-custom-windows-deps.patch74
1 files changed, 74 insertions, 0 deletions
diff --git a/x11-terms/alacritty/files/alacritty-0.2.2-avoid-fetching-custom-windows-deps.patch b/x11-terms/alacritty/files/alacritty-0.2.2-avoid-fetching-custom-windows-deps.patch
new file mode 100644
index 000000000000..320d35dce99a
--- /dev/null
+++ b/x11-terms/alacritty/files/alacritty-0.2.2-avoid-fetching-custom-windows-deps.patch
@@ -0,0 +1,74 @@
+diff --git a/Cargo.lock b/Cargo.lock
+index b6b6528..1a58928 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -60,7 +60,6 @@ dependencies = [
+ "url 1.7.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "vte 0.3.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "winapi 0.3.6 (registry+https://github.com/rust-lang/crates.io-index)",
+- "winpty 0.1.0",
+ "x11-dl 2.18.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "xdg 2.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "zip 0.4.2 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -2654,26 +2653,6 @@ dependencies = [
+ "x11-dl 2.18.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
+-[[package]]
+-name = "winpty"
+-version = "0.1.0"
+-dependencies = [
+- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
+- "named_pipe 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)",
+- "widestring 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
+- "winapi 0.3.6 (registry+https://github.com/rust-lang/crates.io-index)",
+- "winpty-sys 1.1.0 (git+https://github.com/zacps/winpty?branch=rust)",
+-]
+-
+-[[package]]
+-name = "winpty-sys"
+-version = "1.1.0"
+-source = "git+https://github.com/zacps/winpty?branch=rust#9ccec6459c2c8b7555846910c12ba697b688f44d"
+-dependencies = [
+- "bindgen 0.33.2 (registry+https://github.com/rust-lang/crates.io-index)",
+- "cc 1.0.25 (registry+https://github.com/rust-lang/crates.io-index)",
+-]
+-
+ [[package]]
+ name = "winreg"
+ version = "0.4.0"
+@@ -3054,7 +3033,6 @@ dependencies = [
+ "checksum winapi-x86_64-pc-windows-gnu 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f"
+ "checksum wincolor 1.0.1 (registry+https://github.com/rust-lang/crates.io-index)" = "561ed901ae465d6185fa7864d63fbd5720d0ef718366c9a4dc83cf6170d7e9ba"
+ "checksum winit 0.18.0 (registry+https://github.com/rust-lang/crates.io-index)" = "27aa86a5723951d6a08c2acb9f10e25cb39ceb5b1987d7daf74e181b21f8f50b"
+-"checksum winpty-sys 1.1.0 (git+https://github.com/zacps/winpty?branch=rust)" = "<none>"
+ "checksum winreg 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "cbf285379f20d7f26abd990d9a566be9d31ab7a9d335299baaa1f0604f5f96af"
+ "checksum ws2_32-sys 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)" = "d59cefebd0c892fa2dd6de581e937301d8552cb44489cdff035c6187cb63fa5e"
+ "checksum x11-clipboard 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)" = "2e7374c7699210cca7084ca61d57e09640fc744d1391808cb9ae2fe4ca9bd1df"
+diff --git a/Cargo.toml b/Cargo.toml
+index bd74b76..6166187 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -11,8 +11,7 @@ homepage = "https://github.com/jwilm/alacritty"
+ [workspace]
+ members = [
+ "font",
+- "copypasta",
+- "winpty"
++ "copypasta"
+ ]
+
+ [[bin]]
+@@ -53,12 +52,6 @@ url = "1.7.1"
+ [target.'cfg(any(target_os = "linux", target_os = "freebsd", target_os="dragonfly", target_os="openbsd"))'.dependencies]
+ x11-dl = "2"
+
+-[target.'cfg(windows)'.dependencies]
+-winpty = { path = "./winpty" }
+-mio-named-pipes = "0.1"
+-winapi = { version = "0.3.5", features = ["winuser", "synchapi", "roerrorapi", "winerror"]}
+-dunce = "0.1"
+-
+ [target.'cfg(target_os = "macos")'.dependencies]
+ objc = "0.2.2"
+ dirs = "1.0.2"