summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlia Mirkin <imirkin@alum.mit.edu>2022-03-28 01:38:23 -0400
committerMatt Turner <mattst88@gentoo.org>2022-03-29 00:01:40 -0700
commit3cb1463577df401d7de79f1983b9c5adbc3f07ee (patch)
treed7588c4b3e62e4731c3ad85a12652d798b76a628 /x11-terms/aterm
parentnet-misc/icaclient: Bump to version 22.3.0.24 (diff)
downloadgentoo-3cb1463577df401d7de79f1983b9c5adbc3f07ee.tar.gz
gentoo-3cb1463577df401d7de79f1983b9c5adbc3f07ee.tar.bz2
gentoo-3cb1463577df401d7de79f1983b9c5adbc3f07ee.zip
x11-terms/aterm: make background use flag work, drop afterstep reference
The afterstep wm was dropped long ago. Instead, we just need afterimage, which is still in the repository. Fix dependency on that, and drop a bunch of configure flags which no longer do anything. Closes: https://bugs.gentoo.org/833813 Closes: https://github.com/gentoo/gentoo/pull/24786 Signed-off-by: Ilia Mirkin <imirkin@alum.mit.edu> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-terms/aterm')
-rw-r--r--x11-terms/aterm/aterm-1.0.1-r5.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/x11-terms/aterm/aterm-1.0.1-r5.ebuild b/x11-terms/aterm/aterm-1.0.1-r5.ebuild
new file mode 100644
index 000000000000..4a5122d171eb
--- /dev/null
+++ b/x11-terms/aterm/aterm-1.0.1-r5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="rxvt compatible terminal emulator with transparency support"
+HOMEPAGE="http://aterm.sourceforge.net"
+SRC_URI="ftp://ftp.afterstep.org/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="background cjk xgetdefault"
+
+RDEPEND="
+ virtual/jpeg:0
+ media-libs/libpng:0=
+ background? ( media-libs/libafterimage )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libICE
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libXt
+"
+
+PATCHES=(
+ # Security bug #219746
+ "${FILESDIR}/${P}-display-security-issue.patch"
+ "${FILESDIR}/${P}-deadkeys.patch"
+ "${FILESDIR}/${P}-dpy.patch"
+ "${FILESDIR}/${P}-remove-streams.patch"
+)
+
+src_prepare() {
+ # fix pre-stripped files
+ sed -i -e "/INSTALL_PROGRAM/ s:-s::" autoconf/Make.common.in || die "sed Makefile failed"
+
+ default
+}
+
+src_configure() {
+ local myconf
+
+ use cjk && myconf="$myconf
+ --enable-kanji
+ --enable-thai
+ --enable-big5"
+
+ case "${CHOST}" in
+ *-darwin*) myconf="${myconf} --enable-wtmp" ;;
+ *-interix*) ;;
+ *) myconf="${myconf} --enable-utmp --enable-wtmp"
+ esac
+
+ econf \
+ $(use_enable xgetdefault) \
+ $(use_with background afterimage-config "${EPREFIX}"/usr/bin) \
+ --with-terminfo="${EPREFIX}"/usr/share/terminfo \
+ --enable-transparency \
+ --with-x \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ fowners root:utmp /usr/bin/aterm
+ fperms g+s /usr/bin/aterm
+
+ doman doc/aterm.1
+ dodoc ChangeLog doc/FAQ doc/README.*
+ docinto menu
+ dodoc doc/menu/*
+}
+
+pkg_postinst() {
+ echo
+ elog "The transparent background will only work if you have the 'real'"
+ elog "root wallpaper set. Some tools that might help include:"
+ elog "wmsetbg (x11-wm/windowmaker), and/or media-gfx/feh."
+ echo
+}