summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-03 05:52:42 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-03 06:16:17 -0500
commit73027225dcc9df319fb6520c155446be85fa077d (patch)
tree75b8cbb29bcd5cd5dac6f0b1c35e4fad361eb103 /x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.2.ebuild
parentx11-terms/kitty-terminfo: add 0.24.2 (diff)
downloadgentoo-73027225dcc9df319fb6520c155446be85fa077d.tar.gz
gentoo-73027225dcc9df319fb6520c155446be85fa077d.tar.bz2
gentoo-73027225dcc9df319fb6520c155446be85fa077d.zip
x11-terms/kitty-shell-integration: add 0.24.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.2.ebuild')
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.2.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.2.ebuild
new file mode 100644
index 000000000000..80e3667e6412
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+}