summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-03-03 06:43:47 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-03-03 06:43:47 -0500
commit44cc459a7cfdec317bed41fe08d7fa17fc40e20a (patch)
tree5803b8229b3d630f7ffc8534b29bbe1e64ecf1aa /x11-terms/kitty-shell-integration
parentx11-wm/pekwm: version bump 0.2.1 (diff)
downloadgentoo-44cc459a7cfdec317bed41fe08d7fa17fc40e20a.tar.gz
gentoo-44cc459a7cfdec317bed41fe08d7fa17fc40e20a.tar.bz2
gentoo-44cc459a7cfdec317bed41fe08d7fa17fc40e20a.zip
x11-terms/kitty-shell-integration: add 0.24.4
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-shell-integration')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.4.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 90c62e2a5a49..5bc303e1c56c 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1 +1,2 @@
DIST kitty-0.24.3.tar.xz 4614252 BLAKE2B 04c9904e20aae0ed12d41dc01ea4fbb5e36430e50087821845c0bd3e6d8dd0ab2a090f8ebff8fd66fe9f2b0a3efe52f0434008b4484cbe27a58b05c6e4f56d73 SHA512 2b1482164fb1aabfa2f775f24d0ffbbbd1e8a85cf114a2daa411379ea8dbcea6ae5f361997132fb4d773fed8adeec4c04ffb4e615a470cefeb794d8a39c94c0a
+DIST kitty-0.24.4.tar.xz 4613232 BLAKE2B 3bcb957a2d1b43cbf222207fbd12e5d098e0b9616370761d9f9629e8b39419405fb146d91281912f55b35611cf01d4e33232224cc3b710044d8423300c9b53c8 SHA512 28b1e2415b5c73ad8922d4ed17a63638c497a91c9aedba71c2f53e77fc89ed49951a2e873bba5bbe85c8eda22107d9ff4e4321010ac33a2d289c2fbd5d3a5b8f
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.4.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.4.ebuild
new file mode 100644
index 000000000000..80e3667e6412
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+}