summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-05-26 00:40:54 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-05-26 02:06:02 -0400
commitad2e4b78b1d0b8a6994170436c9f1a844c91d734 (patch)
tree1a715bb93c6ebd45a26780f66d3049a28876afda /x11-terms/kitty-shell-integration
parentx11-drivers/nvidia-drivers: drop vuln 390.147, 470.103.01, 510.68.02 (diff)
downloadgentoo-ad2e4b78b1d0b8a6994170436c9f1a844c91d734.tar.gz
gentoo-ad2e4b78b1d0b8a6994170436c9f1a844c91d734.tar.bz2
gentoo-ad2e4b78b1d0b8a6994170436c9f1a844c91d734.zip
x11-terms/kitty-shell-integration: add 0.25.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-shell-integration')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.25.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index c84732ba070b..aaf0e56276fb 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1 +1,2 @@
DIST kitty-0.25.0.tar.xz 4640360 BLAKE2B 2f982ecb2d13c49a6971d4a863f2215f22ccae2cc50fd7b6c6b5c2facf781ac23ec627edcbec8ebaa538c5d67b0b62ad4cc05aedf90fd722d9d886c2f62d5b42 SHA512 fed8d66a9f7f2117f4b495305db0d56d8b85ef03bf7ef24a7dca31e63e16fc90e026aa8022237ad45678efb026f11fdd8aa377eb53917fd8ec885f2ccea721f8
+DIST kitty-0.25.1.tar.xz 4671008 BLAKE2B f5110c64e3659499351875dfb4ad9dba85724184cbb742d4b2fe63dcb604b5c8e8736c51ae126345736cbb90238ba3c9e3de099cd6ebfdd0e50b5dfb36c2d2b6 SHA512 6d9862f8411372e0cf692114d6e29eb92db3a2e324282a21ca35b2ca5229c9d87ab988e802e44d47e98b6e64ae7abc5ff0cc677c082eb287e14ee68cd1a4c31e
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.25.1.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.25.1.ebuild
new file mode 100644
index 000000000000..4c3e987c411b
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.25.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}