summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorend222 <pabloorduna98@gmail.com>2020-04-11 23:25:27 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-13 11:31:18 +0300
commitd0b78893168665b57ab6e93ffc29e4c0a1c519d0 (patch)
treec10fe48527585a2e15ec715a8936a7ae06174950 /x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
parentx11-terms/kitty: fix and split live ebuild (diff)
downloadgentoo-d0b78893168665b57ab6e93ffc29e4c0a1c519d0.tar.gz
gentoo-d0b78893168665b57ab6e93ffc29e4c0a1c519d0.tar.bz2
gentoo-d0b78893168665b57ab6e93ffc29e4c0a1c519d0.zip
x11-terms/kitty-terminfo: split live ebuild
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15308 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild')
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
new file mode 100644
index 000000000000..b43704ce0df0
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1 toolchain-funcs xdg git-r3
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/kitty-terminfo-setup-0.17.2.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+}