summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-19 22:22:39 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-20 17:18:28 -0400
commit12569ce7f9f03201e63ed71dc110ea82be251299 (patch)
tree85984a40c8c7a807a3434c16bb7879735d79a294 /x11-terms/kitty
parentdev-python/jaraco-stream: bump to 1.2, Python 3.6, PyPy{,3} (diff)
downloadgentoo-12569ce7f9f03201e63ed71dc110ea82be251299.tar.gz
gentoo-12569ce7f9f03201e63ed71dc110ea82be251299.tar.bz2
gentoo-12569ce7f9f03201e63ed71dc110ea82be251299.zip
x11-terms/kitty: version bump to 0.11.1
Drop to py36 to work around f-strings docs issue (bug #658304). Closes: https://bugs.gentoo.org/658304
Diffstat (limited to 'x11-terms/kitty')
-rw-r--r--x11-terms/kitty/Manifest1
-rw-r--r--x11-terms/kitty/kitty-0.11.1.ebuild96
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild2
3 files changed, 98 insertions, 1 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index bf8f4bdaf657..8a78f542f8c9 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1,3 +1,4 @@
DIST kitty-0.10.1.tar.gz 3844251 BLAKE2B f2b1e523ae48415c410080ae0b419c96e394bfc145da4c3f73fe865e2b1fbd6f7c8ffd18d4e14ea09c0397b8fceb35ebfce72a49d731886588acea5135d4615a SHA512 5341ebdec5356665db5ed0b9f910dac66860b0b39334c0878a3af637bd3da983c11ab8425794e8ea7b3c90f6d64855d8acda4531f25726c01ab355293f033a08
DIST kitty-0.11.0.tar.gz 3907898 BLAKE2B aed74721a332b41cdfb798097797a4e59c1743d32bf2ae6bf5d90eb571acc5ab93c27f837f17de0f79dcece55ba58b6d178a01df980f19fd5d5c5c11337dba4d SHA512 33e9d0a8de5531d9dad341054dde7986eee9ad9ef1c97809c6ee7f3a5fc5ae210eff59ac02e571c31f233676329143f38f4e95d8971d28b21e6befc362e46984
+DIST kitty-0.11.1.tar.gz 3924068 BLAKE2B a71535cfffe863ee06f699eba3a06c1665c851673bee0d1134fe992fe0335cc13d9a89cebf5814082a155166aaa0939b0e6296ad567564c608bf72eedce5cce3 SHA512 79a3ed4ffbc58e34e6c907646dc33168a8dcb58db859549549e2983186521dc69990e2d2e3eb120fcd31af03187d9a8233a60b75c205ac4e59bb7b575836cceb
DIST kitty-0.9.1.tar.gz 3698447 BLAKE2B f7e5c4d365f4fa3f74a348b219ea2433fc1ad05cca68a5ba920b692a4dd5de63fb27cd28159de3af3f11e9a87911bc8600c342ee2bc733317f91e9a7b6226e15 SHA512 3690dd7308f37de3282148c80e2afffde08e4dc2c459f78668d461461ff5dad2b39127635cf22f0f160f40823d2fa1a43a7e83d4bcc0b64e4cbc6e5be1988329
diff --git a/x11-terms/kitty/kitty-0.11.1.ebuild b/x11-terms/kitty/kitty-0.11.1.ebuild
new file mode 100644
index 000000000000..a60de5a2102f
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.11.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_6 )
+
+inherit python-single-r1 toolchain-funcs gnome2-utils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/kovidgoyal/kitty/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A modern, hackable, featureful, OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug imagemagick wayland"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPS="
+ ${PYTHON_DEPS}
+ >=media-libs/harfbuzz-1.5.0:=
+ sys-libs/zlib
+ media-libs/libpng:0=
+ media-libs/freetype:2
+ media-libs/fontconfig
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libxkbcommon[X]
+ wayland? (
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.12
+ )
+"
+RDEPEND="
+ ${COMMON_DEPS}
+ imagemagick? ( virtual/imagemagick-tools )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.11.0-flags.patch
+ "${FILESDIR}"/${PN}-0.11.0-svg-icon.patch
+)
+
+src_prepare() {
+ default
+
+ # disable wayland as required
+ if ! use wayland; then
+ sed -i "/'x11 wayland'/s/ wayland//" setup.py || die
+ fi
+
+ # respect doc dir
+ sed -i "/htmldir =/s/appname/'${PF}'/" setup.py
+
+ tc-export CC
+}
+
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
+src_compile() {
+ doecho "${EPYTHON}" setup.py --verbose $(usex debug --debug "") --libdir-name $(get_libdir) linux-package
+}
+
+src_test() {
+ export KITTY_CONFIG_DIRECTORY=${T}
+ "${EPYTHON}" test.py || die
+}
+
+src_install() {
+ mkdir -p "${ED}"usr || die
+ cp -r linux-package/* "${ED}usr" || die
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index e1bdc32f631a..a60de5a2102f 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_6 )
inherit python-single-r1 toolchain-funcs gnome2-utils