summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-22 09:29:25 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-22 09:35:49 -0500
commit472650d23e012e92054ebd8c79da7d33e8415769 (patch)
tree65973591e091be486d9aa6479dd55c156c23de1a /x11-terms/kitty
parentx11-terms/kitty: revamp seds in live (diff)
downloadgentoo-472650d23e012e92054ebd8c79da7d33e8415769.tar.gz
gentoo-472650d23e012e92054ebd8c79da7d33e8415769.tar.bz2
gentoo-472650d23e012e92054ebd8c79da7d33e8415769.zip
x11-terms/kitty: fix kitty-tool exec bit in live with rework
Easy to miss changes to this (not limited to /usr/bin) or forget, so just setup a generic way to preserve executable bits. Could use xargs or so, but rather avoid using external version of ebuild helpers if it's simple to. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty')
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 66de305b3f00..c5d812b82614 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -135,8 +135,9 @@ src_install() {
insinto /usr
doins -r linux-package/.
- fperms +x /usr/bin/kitty \
- /usr/$(get_libdir)/kitty/shell-integration/ssh/{askpass.py,kitty}
+ local execbit
+ mapfile -t execbit < <(find linux-package -type f -perm /+x -printf '/usr/%P\n' || die)
+ fperms +x "${execbit[@]}"
}
pkg_postinst() {