summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-10 15:48:49 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-10 15:49:18 +0200
commit76344fabfd15a262985f3705851b374c60187717 (patch)
tree4832a6738e9ee39108cc6214661056964ce56525 /x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
parentwww-apps/piwigo: 2.9.5 bump (diff)
downloadgentoo-76344fabfd15a262985f3705851b374c60187717.tar.gz
gentoo-76344fabfd15a262985f3705851b374c60187717.tar.bz2
gentoo-76344fabfd15a262985f3705851b374c60187717.zip
x11-terms/rxvt-unicode: Add IUSE="utmp wtmp"
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Bug: https://bugs.gentoo.org/683008 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild')
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild42
1 files changed, 21 insertions, 21 deletions
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
index 9a25833630ec..376b8036d825 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools cvs eutils
+EAPI=7
+inherit autotools cvs desktop vcs-clean
DESCRIPTION="rxvt clone with xft and unicode support"
HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
@@ -15,13 +15,13 @@ SLOT="0"
KEYWORDS=""
IUSE="
256-color blink fading-colors +font-styles iso14755 +mousewheel +perl
- pixbuf startup-notification xft unicode3
+ pixbuf startup-notification unicode3 +utmp +wtmp xft
"
RESTRICT="test"
RDEPEND="
+ >=sys-libs/ncurses-5.7-r6:=
media-libs/fontconfig
- sys-libs/ncurses:*
x11-libs/libX11
x11-libs/libXrender
kernel_Darwin? ( dev-perl/Mac-Pasteboard )
@@ -35,30 +35,31 @@ DEPEND="
virtual/pkgconfig
x11-base/xorg-proto
"
-
-S=${WORKDIR}/${PN}
-PATCHES=(
- "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch
- "${FILESDIR}"/${PN}-9.21-xsubpp.patch
-
+DOCS=(
+ Changes
+ README.FAQ
+ doc/README.xvt
+ doc/changes.txt
+ doc/etc/${PN}.term{cap,info}
+ doc/rxvt-tabbed
)
+S=${WORKDIR}/${PN}
src_prepare() {
ecvs_clean
-
- # kill the rxvt-unicode terminfo file - #192083
- sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die
+ eapply \
+ "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch \
+ "${FILESDIR}"/${PN}-9.21-xsubpp.patch
eapply_user
+ # kill the rxvt-unicode terminfo file - #192083
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die "sed failed"
+
eautoreconf
}
src_configure() {
- local myconf=''
-
- use iso14755 || myconf='--disable-iso14755'
-
# --enable-everything goes first: the order of the arguments matters
econf --enable-everything \
$(use_enable 256-color) \
@@ -71,6 +72,8 @@ src_configure() {
$(use_enable pixbuf) \
$(use_enable startup-notification) \
$(use_enable unicode3) \
+ $(use_enable utmp) \
+ $(use_enable wtmp) \
$(use_enable xft)
}
@@ -85,9 +88,6 @@ src_compile() {
src_install() {
default
- dodoc \
- README.FAQ Changes doc/README* doc/changes.txt doc/etc/* doc/rxvt-tabbed
-
make_desktop_entry urxvt rxvt-unicode utilities-terminal \
"System;TerminalEmulator"
}