summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-05-12 12:02:49 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-05-12 12:02:49 +0300
commite2035ecb25f4ebe7f8d729ecf04e2008872a0dc1 (patch)
tree21d38cea3361dee90346902fe63c80dba4500469 /x11-terms/tilda/tilda-1.5.2.ebuild
parentapp-arch/rpm: x86 stable wrt bug #717916 (diff)
downloadgentoo-e2035ecb25f4ebe7f8d729ecf04e2008872a0dc1.tar.gz
gentoo-e2035ecb25f4ebe7f8d729ecf04e2008872a0dc1.tar.bz2
gentoo-e2035ecb25f4ebe7f8d729ecf04e2008872a0dc1.zip
x11-terms/tilda: Version bump (v1.5.2)
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'x11-terms/tilda/tilda-1.5.2.ebuild')
-rw-r--r--x11-terms/tilda/tilda-1.5.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-terms/tilda/tilda-1.5.2.ebuild b/x11-terms/tilda/tilda-1.5.2.ebuild
new file mode 100644
index 000000000000..b7827af4144d
--- /dev/null
+++ b/x11-terms/tilda/tilda-1.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A drop down terminal, similar to the consoles found in first person shooters"
+HOMEPAGE="https://github.com/lanoxx/tilda"
+SRC_URI="https://github.com/lanoxx/tilda/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/vte:2.91
+ >=dev-libs/glib-2.8.4:2
+ dev-libs/confuse:=
+ gnome-base/libglade
+ x11-libs/gtk+:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+ append-cflags -std=c99
+ eautoreconf
+}