summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-15 17:17:34 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-15 17:55:46 +0200
commit3ea261109422f5d48044b32bce8ce17f1aa543cf (patch)
treefb038263d8b7bbd8f9277f72dfc49b8811e1784c /x11-terms/xfce4-terminal/xfce4-terminal-0.8.7.4.ebuild
parentdev-ruby/puppetdb-termini: 5.2.2 stable amd64 and x86 with cleanup (diff)
downloadgentoo-3ea261109422f5d48044b32bce8ce17f1aa543cf.tar.gz
gentoo-3ea261109422f5d48044b32bce8ce17f1aa543cf.tar.bz2
gentoo-3ea261109422f5d48044b32bce8ce17f1aa543cf.zip
x11-terms/xfce4-terminal: Bump to 0.8.7.4
Diffstat (limited to 'x11-terms/xfce4-terminal/xfce4-terminal-0.8.7.4.ebuild')
-rw-r--r--x11-terms/xfce4-terminal/xfce4-terminal-0.8.7.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-terms/xfce4-terminal/xfce4-terminal-0.8.7.4.ebuild b/x11-terms/xfce4-terminal/xfce4-terminal-0.8.7.4.ebuild
new file mode 100644
index 000000000000..4ed3b8ddca72
--- /dev/null
+++ b/x11-terms/xfce4-terminal/xfce4-terminal-0.8.7.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver
+
+DESCRIPTION="A terminal emulator for the Xfce desktop environment"
+HOMEPAGE="https://docs.xfce.org/apps/terminal/start"
+SRC_URI="mirror://xfce/src/apps/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="utempter"
+
+RDEPEND=">=dev-libs/glib-2.32:2=
+ >=x11-libs/gtk+-3.20.8:3=
+ x11-libs/libX11:=
+ >=x11-libs/vte-0.38:2.91=
+ >=xfce-base/libxfce4ui-4.10:=[gtk3(+)]
+ utempter? ( sys-libs/libutempter:= )"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS )
+
+src_configure() {
+ local myconf=(
+ $(use_with utempter)
+ )
+
+ econf "${myconf[@]}"
+}