summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-09-10 13:02:47 +0100
committerMatthew Smith <matthew@gentoo.org>2022-09-10 13:04:00 +0100
commitc0388ff51cbfe987faeef5c1b10d2986e8ed8603 (patch)
tree3757bb3698881a33a70295c182375c10e25998fa /x11-terms/zutty
parentdev-libs/pugixml: sync live, add explanatory comment re SRC_URI (diff)
downloadgentoo-c0388ff51cbfe987faeef5c1b10d2986e8ed8603.tar.gz
gentoo-c0388ff51cbfe987faeef5c1b10d2986e8ed8603.tar.bz2
gentoo-c0388ff51cbfe987faeef5c1b10d2986e8ed8603.zip
x11-terms/zutty: add 0.13
Bug: https://bugs.gentoo.org/868495 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'x11-terms/zutty')
-rw-r--r--x11-terms/zutty/Manifest1
-rw-r--r--x11-terms/zutty/zutty-0.13.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-terms/zutty/Manifest b/x11-terms/zutty/Manifest
index d5b66ef07238..7df3e9de2c97 100644
--- a/x11-terms/zutty/Manifest
+++ b/x11-terms/zutty/Manifest
@@ -1 +1,2 @@
DIST zutty-0.12.tar.gz 348226 BLAKE2B 8d065928fe3e8049e63f1e679d4e8d2ef6643b01b098698594d536c6fa9494a2a934dce3e4fe60594be4f1b56691a83a8e7fab0dd1ec6c09e12eeb1e69354f5e SHA512 d10289a51469ec6352a5b1feefb732dce7cf507b02ce57e64f8f65443f4533b8d61f357dec92cb00b58386416470928d763290a6d4ff714f65f98f1f09d60083
+DIST zutty-0.13.tar.gz 348348 BLAKE2B 35887597798ecee4912a76d74e943ab93682ee637eed0966d70e198d64c9960060eeb1a0b93a76596dd77aeea99b897bd2d54900f10a41a6a786776a5f202997 SHA512 b6514299520562f3ca9f29c80d252a571c0347603c918d15dde095b92be8e96e23a249b23d1d0efc0d7aca03138c07913d7f3dc0f3e91c8bf04e78a3444ac43e
diff --git a/x11-terms/zutty/zutty-0.13.ebuild b/x11-terms/zutty/zutty-0.13.ebuild
new file mode 100644
index 000000000000..77fbbb39baa9
--- /dev/null
+++ b/x11-terms/zutty/zutty-0.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="X terminal emulator rendering through OpenGL ES Compute Shaders"
+HOMEPAGE="https://tomscii.sig7.se/zutty/ https://github.com/tomszilagyi/zutty"
+SRC_URI="https://github.com/tomszilagyi/zutty/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# It is possible to run the tests using virtualx, but it seems to take
+# screenshots of the terminal window, and compares checksums that never
+# seem to match.
+RESTRICT="test"
+
+RDEPEND="
+ media-libs/freetype:2
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Remove default CXX/LDFLAGS, bug #830405.
+ "${FILESDIR}"/${PN}-0.12-cxxflags.patch
+)
+
+DOCS=( doc/KEYS.org doc/USAGE.org )