summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-01-19 10:53:26 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-01-19 10:55:43 -0800
commit024b44d334a3498446092e70a81590a41f509d72 (patch)
treeb0e2a70d6937a7aae689504f3140294460e10c17 /x11-terms
parentx11-terms/alacritty: bump to 0.7.1 (diff)
downloadgentoo-024b44d334a3498446092e70a81590a41f509d72.tar.gz
gentoo-024b44d334a3498446092e70a81590a41f509d72.tar.bz2
gentoo-024b44d334a3498446092e70a81590a41f509d72.zip
x11-terms/alacritty: sync live ebuild
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/alacritty/alacritty-9999.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/x11-terms/alacritty/alacritty-9999.ebuild b/x11-terms/alacritty/alacritty-9999.ebuild
index 7b2029ef5c69..600107ef5848 100644
--- a/x11-terms/alacritty/alacritty-9999.ebuild
+++ b/x11-terms/alacritty/alacritty-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2017-2020 Gentoo Authors
+# Copyright 2017-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,7 +21,7 @@ if [ ${PV} == "9999" ] ; then
else
SRC_URI="https://github.com/alacritty/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
$(cargo_crate_uris ${CRATES})"
- KEYWORDS="~amd64 ~arm64 ~ppc64"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions Boost-1.0 BSD BSD-2 CC0-1.0 FTL ISC MIT MPL-2.0 Unlicense WTFPL-2 ZLIB"
@@ -114,3 +114,13 @@ src_test() {
cd alacritty || die
cargo_src_test
}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ einfo "Configuration files for ${CATEGORY}/${PN}"
+ einfo "in \$HOME may need to be updated after a version change"
+ einfo ""
+ einfo "An up-to-date sample configuration file can be found at"
+ einfo "${ROOT}/usr/share/doc/${PF}/alacritty.yml.bz2"
+ fi
+}