summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPablo <pord@tuta.io>2020-04-05 12:42:41 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-05 17:26:44 +0300
commit132211216ff9b61393fb3bd20cbb338a453c68fa (patch)
treefffa14d78c7fe2296955b31f891be69fca4c3cb2 /x11-terms
parentapp-arch/engrampa: reorder eclass inherits (diff)
downloadgentoo-132211216ff9b61393fb3bd20cbb338a453c68fa.tar.gz
gentoo-132211216ff9b61393fb3bd20cbb338a453c68fa.tar.bz2
gentoo-132211216ff9b61393fb3bd20cbb338a453c68fa.zip
x11-terms/kitty-terminfo: bump to 0.17.2
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Closes: https://bugs.gentoo.org/716128 Closes: https://github.com/gentoo/gentoo/pull/15227 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch44
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild41
3 files changed, 86 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 67976bd3bd00..15b7b5f10e3a 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1 +1,2 @@
DIST kitty-0.16.0.tar.xz 2974592 BLAKE2B 971e279cd24369a454495fc7a236356e6a4ee69a0953563a9283a16e21bd67ddea5ab8f795c75be6cd31d05c5f1b39b1525e957b9bcd59d12ea3e701b21aa59c SHA512 24dedfc58c5d33aa18da85f904952129f39cd54afb70282c7572b57514b1deebfb532414913e0efc3a5c0352a81406cd7ddef99490dbd9186dc61eab7af3975b
+DIST kitty-0.17.2.tar.xz 3044140 BLAKE2B 12dcb8ddb7d90a22904f575301e8c2b1672c3212ee29a035fa5e8eec553dafb0e2c8c1cc3a491c8ac6854d619e979e518d83c5218f36647a032a4f847d068ef3 SHA512 bccf1c1d60d1149bc5f849b82db1af80a2d9a7a11c5f2df853daae5700550eef98da389a30f015d67be796f39deacb31f3ee245eb37ba1a41ba377c70cd26d61
diff --git a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch
new file mode 100644
index 000000000000..31aa669e0a5e
--- /dev/null
+++ b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch
@@ -0,0 +1,44 @@
+--- a/setup.py 2020-03-12 00:28:46.725956882 +0100
++++ b/setup.py 2020-03-12 00:38:55.557945979 +0100
+@@ -876,6 +876,14 @@
+ create_macos_bundle_gunk(ddir)
+ # }}}
+
++def terminfo(args):
++ ddir = args.prefix
++ libdir = os.path.join(ddir, args.libdir_name.strip('/'), 'kitty')
++ build_terminfo = runpy.run_path('build-terminfo', run_name='import_build')
++ for x in (libdir, os.path.join(ddir, 'share')):
++ odir = os.path.join(x, 'terminfo')
++ safe_makedirs(odir)
++ build_terminfo['compile_terminfo'](odir)
+
+ def clean():
+
+@@ -889,7 +897,7 @@
+
+ safe_remove(
+ 'build', 'compile_commands.json', 'link_commands.json',
+- 'linux-package', 'kitty.app', 'asan-launcher',
++ 'linux-package', 'linux-terminfo', 'kitty.app', 'asan-launcher',
+ 'kitty-profile', 'kitty/launcher')
+ exclude = ('.git',)
+ for root, dirs, files in os.walk('.', topdown=True):
+@@ -910,7 +918,7 @@
+ 'action',
+ nargs='?',
+ default=Options.action,
+- choices='build test linux-package kitty.app linux-freeze macos-freeze clean'.split(),
++ choices='build test linux-package linux-terminfo kitty.app linux-freeze macos-freeze clean'.split(),
+ help='Action to perform (default is build)'
+ )
+ p.add_argument(
+@@ -1007,6 +1015,8 @@
+ elif args.action == 'linux-package':
+ build(args, native_optimizations=False)
+ package(args, bundle_type='linux-package')
++ elif args.action == 'linux-terminfo':
++ terminfo(args)
+ elif args.action == 'linux-freeze':
+ build(args, native_optimizations=False)
+ package(args, bundle_type='linux-freeze')
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild
new file mode 100644
index 000000000000..b37c1bba5c12
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1 toolchain-funcs xdg
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/kitty-terminfo-setup-0.17.2.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+}