summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-11-08 05:24:54 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-11-08 05:29:56 -0500
commit27567f8df27d60779c32406c2fe67037239697a9 (patch)
treecc4bfc0b9b75107a990b72ae5ab2f3fddc2ac6ae /x11-terms
parentx11-terms/kitty-shell-integration: add 0.31.0 (diff)
downloadgentoo-27567f8df27d60779c32406c2fe67037239697a9.tar.gz
gentoo-27567f8df27d60779c32406c2fe67037239697a9.tar.bz2
gentoo-27567f8df27d60779c32406c2fe67037239697a9.zip
x11-terms/kitty-terminfo: add 0.31.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.31.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 8387fde7d7a2..68bab12ef963 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1 +1,2 @@
DIST kitty-0.30.1.tar.xz 7799076 BLAKE2B 99ada03fa957819e716d3225fbee20af62135ff8861d3a6ce8aaf442b4526a69f34dae0ec126db48a4336fcbd2dfde5583e2ff8f16140e938fada6c0a8854a60 SHA512 e5fd68b8acf3eae8f53a2c27101d998eb0d8eff1571de1b03ab431bceafcab0efae821590684ec48b5ed6e3d86fb984d9e04784022ba50c0378d37a68598f9ed
+DIST kitty-0.31.0.tar.xz 7929620 BLAKE2B 74ccd0e14803ee3991d895c8ec0099567b6a087110eda03d5b35a45d1e684916d63846f1bd1184b2f5fe7a88431983602899cfd6392c28de78d020b8c98c89b2 SHA512 3868431003f9f1a3907415124c1d8282b077985a9d104615d48f9d309f6fbf1a11119546674508649aa35f2b6e66aa5638024e8127f92ae7b043da367c7b3363
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.31.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.31.0.ebuild
new file mode 100644
index 000000000000..f217412c7ed0
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.31.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}