summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-27 21:23:14 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-27 21:23:14 -0400
commit31404db58d995516ed4065244211ea9cd91c492d (patch)
treec6990ae9c243229cde45df42fd96cc80185c7f2a /x11-terms
parentx11-terms/kitty-shell-integration: add 0.29.2 (diff)
downloadgentoo-31404db58d995516ed4065244211ea9cd91c492d.tar.gz
gentoo-31404db58d995516ed4065244211ea9cd91c492d.tar.bz2
gentoo-31404db58d995516ed4065244211ea9cd91c492d.zip
x11-terms/kitty-terminfo: add 0.29.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.29.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 4f864fbc6a35..c755a2502313 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.27.1.tar.xz 5045588 BLAKE2B 2381b3e9af26bb8a4c4358318289e9ef49ba1e38678ef192fd815ced962644671433a80f124579fb593257351cd8e0a61f845975d61d0d33f42b9d470ef130f0 SHA512 484d451b418defc7256319730d623224e3744d6200989d92839c40c951fdb213fe2ef472ddf968f695e499aa6c35d994ad76bb0eb28bca80ec8644b2ead40d56
DIST kitty-0.29.1.tar.xz 7809084 BLAKE2B eba6bbe0fc69184a2b73088fff2859d49d06f030128306e761c16142872ceb280b3f034e86190614e68dd0703e8e0506ad5a1d4c4dd9fa64f22c9274d45952e2 SHA512 ce09342ed3cbb0a518dde8d33606468ee5a2a164f18ff4c8addbd33b05459407d4a935b93acb0e98df8d618aa832c93f91e9ac060e7f87c1e4567484adc46c9c
+DIST kitty-0.29.2.tar.xz 7809388 BLAKE2B 6928d79a6cc0eaac4d92ce3babbeb0a42bf1dbc92b775386b521c8399352ba77ab9828f8cfd9f40c3e4f29ae98852b6f3cb9ee1f412474ba2ef655c18d2c294d SHA512 a34d8b5bc817dd9d27f1afa190856d916576f52458ede2253655b294358b6b89b1f103acb90d8d66a494b346420ddedc9fcf1a3399f561268ded82e7b1954b06
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.29.2.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.29.2.ebuild
new file mode 100644
index 000000000000..f217412c7ed0
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.29.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}