summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-04-11 16:36:59 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-04-11 19:19:02 -0400
commit44a1fc2f1a39754b769974ab7cfa146b1089a14f (patch)
tree86a62fee482394439432eaad60fd136377533820 /x11-terms
parentx11-terms/kitty-terminfo: add 0.25.0 (diff)
downloadgentoo-44a1fc2f1a39754b769974ab7cfa146b1089a14f.tar.gz
gentoo-44a1fc2f1a39754b769974ab7cfa146b1089a14f.tar.bz2
gentoo-44a1fc2f1a39754b769974ab7cfa146b1089a14f.zip
x11-terms/kitty-shell-integration: add 0.25.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.25.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index f46355894f81..9edf9fc6eacf 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1 +1,2 @@
DIST kitty-0.24.4.tar.xz 4613232 BLAKE2B 3bcb957a2d1b43cbf222207fbd12e5d098e0b9616370761d9f9629e8b39419405fb146d91281912f55b35611cf01d4e33232224cc3b710044d8423300c9b53c8 SHA512 28b1e2415b5c73ad8922d4ed17a63638c497a91c9aedba71c2f53e77fc89ed49951a2e873bba5bbe85c8eda22107d9ff4e4321010ac33a2d289c2fbd5d3a5b8f
+DIST kitty-0.25.0.tar.xz 4640360 BLAKE2B 2f982ecb2d13c49a6971d4a863f2215f22ccae2cc50fd7b6c6b5c2facf781ac23ec627edcbec8ebaa538c5d67b0b62ad4cc05aedf90fd722d9d886c2f62d5b42 SHA512 fed8d66a9f7f2117f4b495305db0d56d8b85ef03bf7ef24a7dca31e63e16fc90e026aa8022237ad45678efb026f11fdd8aa377eb53917fd8ec885f2ccea721f8
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.25.0.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.25.0.ebuild
new file mode 100644
index 000000000000..4c3e987c411b
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.25.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}