summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-06-07 23:31:17 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-06-07 23:31:37 -0500
commit481f83f4ef8e964665e51ba878ee7f5312359082 (patch)
tree1047c71defc3593e701e1f128f85e2dd904610b0 /x11-terms
parentdev-util/meson: arm64 stable (bug #686874) (diff)
downloadgentoo-481f83f4ef8e964665e51ba878ee7f5312359082.tar.gz
gentoo-481f83f4ef8e964665e51ba878ee7f5312359082.tar.bz2
gentoo-481f83f4ef8e964665e51ba878ee7f5312359082.zip
x11-terms/kitty: fix 9999 builds
Package-Manager: Portage-2.3.66, Repoman-2.3.14 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/files/kitty-9999-flags.patch47
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild2
2 files changed, 48 insertions, 1 deletions
diff --git a/x11-terms/kitty/files/kitty-9999-flags.patch b/x11-terms/kitty/files/kitty-9999-flags.patch
new file mode 100644
index 000000000000..fe54a959cb78
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-9999-flags.patch
@@ -0,0 +1,47 @@
+--- kitty-0.13.2/setup.py
++++ kitty-0.13.2/setup.py
+@@ -178,7 +178,7 @@
+ df = '-g3'
+ if ccver >= (5, 0):
+ df += ' -Og'
+- optimize = df if debug or sanitize else '-O3'
++ optimize = ''
+ sanitize_args = get_sanitize_args(cc, ccver) if sanitize else set()
+ cppflags = os.environ.get(
+ 'OVERRIDE_CPPFLAGS', (
+@@ -191,7 +191,7 @@
+ cflags = os.environ.get(
+ 'OVERRIDE_CFLAGS', (
+ '-Wextra -Wno-missing-field-initializers -Wall -Wstrict-prototypes -std=c11'
+- ' -pedantic-errors -Werror {} {} -fwrapv {} {} -pipe {} -fvisibility=hidden'
++ ' -pedantic-errors {} {} -fwrapv {} {} {} -fvisibility=hidden'
+ ).format(
+ optimize,
+ ' '.join(sanitize_args),
+@@ -205,7 +205,7 @@
+ )
+ ldflags = os.environ.get(
+ 'OVERRIDE_LDFLAGS',
+- '-Wall ' + ' '.join(sanitize_args) + ('' if debug else ' -O3')
++ '-Wall ' + ' '.join(sanitize_args)
+ )
+ ldflags = shlex.split(ldflags)
+ ldflags.append('-shared')
+@@ -517,14 +517,14 @@
+
+
+ def build_launcher(args, launcher_dir='.', for_bundle=False, sh_launcher=False, for_freeze=False):
+- cflags = '-Wall -Werror -fpie'.split()
++ cflags = '-Wall -fpie'.split()
+ cppflags = []
+ libs = []
+ if args.profile:
+ cppflags.append('-DWITH_PROFILER'), cflags.append('-g')
+ libs.append('-lprofiler')
+- else:
+- cflags.append('-O3')
++ #else:
++ # cflags.append('-O3')
+ if for_bundle or for_freeze:
+ cppflags.append('-DFOR_BUNDLE')
+ cppflags.append('-DPYVER="{}"'.format(sysconfig.get_python_version()))
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 74d2102fb6d1..4e18d020cf5a 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -52,8 +52,8 @@ DEPEND="${RDEPEND}
[[ ${PV} == *9999 ]] && DEPEND+=" >=dev-python/sphinx-1.7[${PYTHON_USEDEP}]"
PATCHES=(
- "${FILESDIR}"/${PN}-0.13.2-flags.patch
"${FILESDIR}"/${PN}-0.11.0-svg-icon.patch
+ "${FILESDIR}"/${P}-flags.patch
)
src_prepare() {