summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-07 10:36:47 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-07 10:57:22 -0500
commit4fc8d492b05c8f805c0afb397fa27eb0a7ea1470 (patch)
tree45e57e2f0eda0502b2615a24ffeb59bac72f2b52 /x11-terms
parentwww-client/chromium: adjust libpng dep (diff)
downloadgentoo-4fc8d492b05c8f805c0afb397fa27eb0a7ea1470.tar.gz
gentoo-4fc8d492b05c8f805c0afb397fa27eb0a7ea1470.tar.bz2
gentoo-4fc8d492b05c8f805c0afb397fa27eb0a7ea1470.zip
x11-terms/kitty-shell-integration: add 0.26.5
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 5ff92e08bc45..6ddb75f6c97a 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1 +1,2 @@
DIST kitty-0.26.4.tar.xz 4749148 BLAKE2B fe15d2bd3afda49fcdc911d0ada5824dffe7eac69cd22581b86f50b0d20330ef10bf567d4adfafe5e06d20f9d7a10c8acfcffb95a3d5c47c50327576d9600761 SHA512 4d3ef5ba2ca54d0f5cd84ece771297c19c05bd276fc235f92c76d469ad17e55b54de696dce38c9039ae9825c7609e03e937536261c4fb680e936865ee0e4441e
+DIST kitty-0.26.5.tar.xz 4749988 BLAKE2B 488969b4d7c6aed489a540a8e3bee183345fcfb7e05ae5604f4af40f0720ed931cff82cf389e2fa4015eed74762c0630481a99eeb9302c22c89c4f3e247170d4 SHA512 086ae03d0e382afbe3001e357ef51388c7a8e81fa5b4bf9ce8b123a7fc8bfff3bd68d074e926f540a1f2b83062baa831e44d29c017cabfe8221bebe49b64e808
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.5.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.5.ebuild
new file mode 100644
index 000000000000..92b178c54f24
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}