summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-01-09 23:04:07 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-01-09 23:04:07 +0900
commit642dcb64c865d0028838d42c0342c8011c3d1fa4 (patch)
tree1d3abbc596ee668a5fb2fc0636c0a2f151928975 /x11-terms
parentapp-text/po4a: drop old (diff)
downloadgentoo-642dcb64c865d0028838d42c0342c8011c3d1fa4.tar.gz
gentoo-642dcb64c865d0028838d42c0342c8011c3d1fa4.tar.bz2
gentoo-642dcb64c865d0028838d42c0342c8011c3d1fa4.zip
x11-terms/mlterm: new upstream release
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/mlterm/Manifest1
-rw-r--r--x11-terms/mlterm/mlterm-3.8.9.ebuild128
2 files changed, 129 insertions, 0 deletions
diff --git a/x11-terms/mlterm/Manifest b/x11-terms/mlterm/Manifest
index 00bf14ee21ef..789cec8634a1 100644
--- a/x11-terms/mlterm/Manifest
+++ b/x11-terms/mlterm/Manifest
@@ -1,2 +1,3 @@
DIST mlterm-3.8.7.tar.gz 3994292 BLAKE2B c30991a7bb3a9f0a36d9f898087bda5b86e8282bc811e60430dc61ddd04c8c4cb6b9284ab178d8a6610aca2dcac785326e69e2088b2a7dee786451aa7c6a794c SHA512 6d2087d1433918f476e35dbde8d79940170fa6f133b9122e1db19006afc5081dbad7ed487bfa939b3d92ea29f3843a2b7c5540dc05e54b3c568bbe76ceb66ad2
DIST mlterm-3.8.8.tar.gz 4035215 BLAKE2B 4ef85822915a1a15119ed771e0d2da0158e469b60cc8eafa9a118ba0ee0e4d4191fb0b5e371320978ff83b79907a42c9065d374dff8774bbac73f7ddb57be0af SHA512 4db7de441300d30eadc85d1c780bb10c81d2555225fe163280508180ccc2114eeacf0e5772f9d69c1b59ef6f3ffb3444b75fe3e5ea508dd9e18e5850e78f78a5
+DIST mlterm-3.8.9.tar.gz 4101898 BLAKE2B 81ce300f16dcf6bc1f3e0467fc4646aa263a222965f10d87a8010a70af9f675965f184a5f1a7909b43d6375fc951e98854ee41af10c2cebfd03697560fb5856b SHA512 0bd5468dc58095fd9432922490178fe14335724cee08d2f509e8f72a4d5f9aea9ff2f0672706e5290219575f47a1ff15dccb4e21e318c89dd5718fe6ef694c0c
diff --git a/x11-terms/mlterm/mlterm-3.8.9.ebuild b/x11-terms/mlterm/mlterm-3.8.9.ebuild
new file mode 100644
index 000000000000..b4ee59771b3e
--- /dev/null
+++ b/x11-terms/mlterm/mlterm-3.8.9.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit desktop
+
+DESCRIPTION="A multi-lingual terminal emulator"
+HOMEPAGE="http://mlterm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="bidi brltty cairo canna debug fbcon fcitx freewnn gtk gtk2 harfbuzz ibus libssh2 m17n-lib nls regis scim skk static-libs uim utempter wayland xft"
+REQUIRED_USE="gtk2? ( gtk )"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ bidi? ( dev-libs/fribidi )
+ brltty? ( app-accessibility/brltty )
+ cairo? ( x11-libs/cairo[X(+)] )
+ canna? ( app-i18n/canna )
+ fbcon? ( media-fonts/unifont )
+ fcitx? ( app-i18n/fcitx )
+ freewnn? ( app-i18n/freewnn )
+ gtk? (
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )
+ )
+ harfbuzz? ( media-libs/harfbuzz[truetype(+)] )
+ ibus? ( app-i18n/ibus )
+ libssh2? ( net-libs/libssh2 )
+ m17n-lib? ( dev-libs/m17n-lib )
+ nls? ( virtual/libintl )
+ regis? (
+ || (
+ media-libs/sdl-ttf
+ media-libs/sdl2-ttf
+ )
+ )
+ scim? ( app-i18n/scim )
+ skk? (
+ || (
+ virtual/skkserv
+ app-i18n/skk-jisyo
+ )
+ )
+ uim? ( app-i18n/uim )
+ utempter? ( sys-libs/libutempter )
+ wayland? ( dev-libs/wayland )
+ xft? ( x11-libs/libXft )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${PN}-font.patch )
+DOCS=( doc/{en,ja} )
+
+src_prepare() {
+ # default config
+ sed -i \
+ -e "/ icon_path =/aicon_path = ${EPREFIX}/usr/share/pixmaps/${PN}-icon.svg" \
+ -e "/ scrollbar_view_name =/ascrollbar_view_name = sample" \
+ etc/main
+
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable bidi fribidi)
+ $(use_enable brltty brlapi)
+ $(use_enable canna)
+ $(use_enable debug)
+ $(use_enable fcitx)
+ $(use_enable freewnn wnn)
+ $(use_enable harfbuzz otl)
+ $(use_enable ibus)
+ $(use_enable libssh2 ssh2)
+ $(use_enable m17n-lib m17nlib)
+ $(use_enable nls)
+ $(use_enable scim)
+ $(use_enable skk)
+ $(use_enable uim)
+ $(use_enable utempter utmp)
+ --with-gui=xlib$(usex fbcon ",fb" "")$(usex wayland ",wayland" "")
+ --with-type-engines=xcore$(usex xft ",xft" "")$(usex cairo ",cairo" "")
+ --enable-optimize-redrawing
+ --enable-vt52
+ --disable-static
+ )
+
+ local scrollbars="sample,extra"
+ local tools="mlclient,mlcc,mlfc,mlmenu,${PN}-zoom"
+ if use gtk; then
+ myconf+=(
+ $(use_with gtk gtk $(usex gtk2 2.0 3.0))
+ --with-imagelib=gdk-pixbuf
+ )
+ scrollbars+=",pixmap_engine"
+ tools+=",mlconfig,mlimgloader"
+ fi
+ if use regis; then
+ tools+=",registobmp"
+ fi
+ myconf+=( --with-scrollbars="${scrollbars}" )
+ myconf+=( --with-tools="${tools}" )
+
+ addpredict /dev/ptmx
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ :
+}
+
+src_install () {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ docinto contrib/icon
+ dodoc contrib/icon/README
+
+ doicon contrib/icon/${PN}*
+ make_desktop_entry ${PN} ${PN} ${PN}-icon "System;TerminalEmulator"
+}