summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-07-13 22:16:36 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-14 05:30:03 -0400
commit6cfc3c38d2c83824786e2a63797f9cea9b330023 (patch)
treebd4f3d8b0b73d93c49e79c936117d492ab0dc248 /x11-terms
parentmedia-sound/rosegarden: Stabilize 23.06 x86, #910312 (diff)
downloadgentoo-6cfc3c38d2c83824786e2a63797f9cea9b330023.tar.gz
gentoo-6cfc3c38d2c83824786e2a63797f9cea9b330023.tar.bz2
gentoo-6cfc3c38d2c83824786e2a63797f9cea9b330023.zip
x11-terms/kitty: Backport fix for musl 1.2.4
Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/31872 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/files/kitty-0.29.0-musl-1.2.4.patch20
-rw-r--r--x11-terms/kitty/kitty-0.27.1.ebuild4
-rw-r--r--x11-terms/kitty/kitty-0.28.1.ebuild4
-rw-r--r--x11-terms/kitty/kitty-0.29.0.ebuild4
4 files changed, 32 insertions, 0 deletions
diff --git a/x11-terms/kitty/files/kitty-0.29.0-musl-1.2.4.patch b/x11-terms/kitty/files/kitty-0.29.0-musl-1.2.4.patch
new file mode 100644
index 000000000000..f02f425d0d66
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-0.29.0-musl-1.2.4.patch
@@ -0,0 +1,20 @@
+From https://github.com/kovidgoyal/kitty/commit/90223b5d146828c65179da49c75ce31b304fa1b8 Mon Sep 17 00:00:00 2001
+From: Kovid Goyal <kovid@kovidgoyal.net>
+Date: Tue, 11 Jul 2023 09:22:40 +0530
+Subject: [PATCH] Fix compilation against musl
+
+As usual in C stdlib world. Ill thought out break the world changes.
+Sigh. musl no longer defines off64_t.
+
+Fixes #6441
+--- a/kitty/fast-file-copy.c
++++ b/kitty/fast-file-copy.c
+@@ -83,7 +83,7 @@ copy_with_file_range(int infd, int outfd, off_t in_pos, size_t len, FastFileCopy
+ #ifdef HAS_COPY_FILE_RANGE
+ unsigned num_of_consecutive_zero_returns = 128;
+ while (len) {
+- off64_t r = in_pos;
++ int64_t r = in_pos;
+ ssize_t n = copy_file_range(infd, &r, outfd, NULL, len, 0);
+ if (n < 0) {
+ if (errno == EAGAIN) continue;
diff --git a/x11-terms/kitty/kitty-0.27.1.ebuild b/x11-terms/kitty/kitty-0.27.1.ebuild
index 1fa60113f89c..f0f229436c3f 100644
--- a/x11-terms/kitty/kitty-0.27.1.ebuild
+++ b/x11-terms/kitty/kitty-0.27.1.ebuild
@@ -70,6 +70,10 @@ BDEPEND="
wayland? ( dev-util/wayland-scanner )"
[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.29.0-musl-1.2.4.patch"
+)
+
QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
src_unpack() {
diff --git a/x11-terms/kitty/kitty-0.28.1.ebuild b/x11-terms/kitty/kitty-0.28.1.ebuild
index e034994923d5..00cbcf7ed7e4 100644
--- a/x11-terms/kitty/kitty-0.28.1.ebuild
+++ b/x11-terms/kitty/kitty-0.28.1.ebuild
@@ -70,6 +70,10 @@ BDEPEND="
wayland? ( dev-util/wayland-scanner )"
[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.29.0-musl-1.2.4.patch"
+)
+
QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
src_unpack() {
diff --git a/x11-terms/kitty/kitty-0.29.0.ebuild b/x11-terms/kitty/kitty-0.29.0.ebuild
index ca29cc5189de..73a34d22e2c4 100644
--- a/x11-terms/kitty/kitty-0.29.0.ebuild
+++ b/x11-terms/kitty/kitty-0.29.0.ebuild
@@ -70,6 +70,10 @@ BDEPEND="
wayland? ( dev-util/wayland-scanner )"
[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.29.0-musl-1.2.4.patch"
+)
+
QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
src_unpack() {