summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2019-05-25 08:00:34 +0300
committerMichał Górny <mgorny@gentoo.org>2019-05-26 13:34:08 +0200
commit8f9b5ccdce5655e7834871846547b860c269399a (patch)
tree3c3a8b5bdc7f06c70d4eb419773ef66ce98d8a5a /x11-terms
parentsci-libs/libcerf: amd64 stable wrt bug #685690 (diff)
downloadgentoo-8f9b5ccdce5655e7834871846547b860c269399a.tar.gz
gentoo-8f9b5ccdce5655e7834871846547b860c269399a.tar.bz2
gentoo-8f9b5ccdce5655e7834871846547b860c269399a.zip
x11-terms/terminology: bump to 1.4.1
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Joonas Niilola <juippis@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/terminology/Manifest1
-rw-r--r--x11-terms/terminology/terminology-1.4.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index 8678ec96d460..50788de725db 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1,2 +1,3 @@
DIST terminology-1.3.2.tar.xz 4849832 BLAKE2B db03ab8d40a432e42d645a53a02b96afa37a6d238cb26bea55de6153969164e53986d70091239235ba724556feaa32bc8de68aba5fb766543f1719791f0c5ab6 SHA512 e41e413348451e0df90634af06fb49ec830f9b1454eec2601977e6e35385bd1a62a385a9ab7fc02fc6c3750f5b73785e4f40f14bb36acd58d4c296074b5f32c8
DIST terminology-1.4.0.tar.xz 4878656 BLAKE2B 7e6b41e1057aa245c9cbcbdf164efd68cef7d3bc92706d10d100bface25a7e29468512ee690795e9f09242b644d80215239f761fe7216ea5d768f48259436778 SHA512 c7fd6605c00983e79a647b1e577868e5d2b713321164cb0ee8ef4b4a4155bf320f3e145ce91ecf1d3b0c40f28ae360b96798e47fd11accfa230932cfbd9e5c9e
+DIST terminology-1.4.1.tar.xz 4878484 BLAKE2B a8ec1a6f3a80057316c6c90ea60c2a273702dfbe7dae70fac649c9bbe3245ea8fbacc625a9b9430dbb969cc02b79792f189ea1c16b2ebc0dee9eeb0242dda8f4 SHA512 5756b09aa0f92f9e1fea17d399eca161272a8514e29343873024b9727eaaeeca0b7efe465c01e42cd548b37cf0da7d99733a789921093700519f80a2952f0706
diff --git a/x11-terms/terminology/terminology-1.4.1.ebuild b/x11-terms/terminology/terminology-1.4.1.ebuild
new file mode 100644
index 000000000000..65b045e742ae
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg-utils
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="extras nls"
+
+RDEPEND="
+ || ( dev-libs/efl[gles2] dev-libs/efl[opengl] )
+ || ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ app-arch/lz4
+ dev-libs/efl[eet,fontconfig]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ $(meson_use extras tests)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}