summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-08-12 08:55:12 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-08-12 08:56:02 +0300
commitab1bc5f2b06f37292b38b2b7b5b8b7a22138fae7 (patch)
treed9f7b76ef3c384db1f719708be3b17ecdba32467 /x11-terms
parentsys-apps/systemd: arm64 stable (bug #731946) (diff)
downloadgentoo-ab1bc5f2b06f37292b38b2b7b5b8b7a22138fae7.tar.gz
gentoo-ab1bc5f2b06f37292b38b2b7b5b8b7a22138fae7.tar.bz2
gentoo-ab1bc5f2b06f37292b38b2b7b5b8b7a22138fae7.zip
x11-terms/terminology: bump to 1.8.1
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/terminology/Manifest1
-rw-r--r--x11-terms/terminology/terminology-1.8.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index 952fad350ddf..fe68d3d0645a 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1,2 +1,3 @@
DIST terminology-1.7.0.tar.xz 4922616 BLAKE2B 40ca7bfff534e773b4c188970ecd82e44c2eee7a75eb2a6d4fc6a8635c57857e2037a319818a437843271faa42995f25b613091a4463c02427d835c6ae572722 SHA512 9635da6a51344fbbafd333592252c2539daa795600b4a1d5ea5710e294f18ff9f5667706c789a3c91378b493ae631df47faec2bc43b4cc48d0266506ab3f2e78
DIST terminology-1.8.0.tar.xz 4938932 BLAKE2B 06d3cb7e4b1f7c069f44e1f7a78d29fe07bb4910e8f9b210363b96f18338f2eb97f247279e4e1e4d2f27ff48db35844f94dabee23a5ca50a6faecada0151bae8 SHA512 2d99b010e6a68f5cbe2d783138cd7321d878206f8000f3f6c59446bc4c998cb4944925ff61356f979c35c115fc87e311d7abbb12919ed52ef36ea9ff25c44d8f
+DIST terminology-1.8.1.tar.xz 4939080 BLAKE2B a87f6f27eca41b4e98d0d26c488ff9075e99e9ba99ef098db54069254a162c9e6f626716d650b6d04004e8f24fd2bcc36422de1834c575f95556612167b4f8a5 SHA512 9b12540d0e907ee1499c3249f1e2dbf7786f401e2154856a804dc0a1afbe389cb297b237fdc1c38aff8b81ba1f65d70cf3a27c986ec8cccef6f03894feadf14f
diff --git a/x11-terms/terminology/terminology-1.8.1.ebuild b/x11-terms/terminology/terminology-1.8.1.ebuild
new file mode 100644
index 000000000000..6ebec04fc712
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.8.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg-utils
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/terminology/${P}.tar.xz https://downloads.terminolo.gy/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="extras nls"
+
+RDEPEND="|| ( dev-libs/efl[gles2-only] dev-libs/efl[opengl] )
+ || ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ app-arch/lz4
+ dev-libs/efl[eet,fontconfig]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ $(meson_use extras tests)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}