summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-02-21 13:13:47 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-21 13:13:47 +0100
commitcb5a294ea69ba4f1c8cd516df2529b41e97d3bbe (patch)
treec66a74aa9ef0945bf54f787ae578d6f946eb355d /x11-terms
parentapp-misc/ca-certificates: Removed old (diff)
downloadgentoo-cb5a294ea69ba4f1c8cd516df2529b41e97d3bbe.tar.gz
gentoo-cb5a294ea69ba4f1c8cd516df2529b41e97d3bbe.tar.bz2
gentoo-cb5a294ea69ba4f1c8cd516df2529b41e97d3bbe.zip
x11-terms/guake: Add python 3.9
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/guake/guake-3.7.0.ebuild26
-rw-r--r--x11-terms/guake/guake-9999.ebuild28
2 files changed, 31 insertions, 23 deletions
diff --git a/x11-terms/guake/guake-3.7.0.ebuild b/x11-terms/guake/guake-3.7.0.ebuild
index 4e93b1c4469b..41b6853d6587 100644
--- a/x11-terms/guake/guake-3.7.0.ebuild
+++ b/x11-terms/guake/guake-3.7.0.ebuild
@@ -1,21 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..8} )
+
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1 gnome2-utils xdg-utils
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Guake/guake.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="amd64 arm x86"
+fi
+
DESCRIPTION="Drop-down terminal for GNOME"
HOMEPAGE="
https://github.com/Guake/guake/
https://pypi.org/project/guake/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 arm x86"
IUSE="utempter"
RDEPEND="
@@ -30,14 +37,11 @@ RDEPEND="
x11-libs/libnotify[introspection]
x11-libs/libwnck:3[introspection]
x11-libs/vte:2.91[introspection]
- utempter? ( sys-libs/libutempter )
-"
-DEPEND="
- ${RDEPEND}
+ utempter? ( sys-libs/libutempter )"
+DEPEND="${RDEPEND}"
+BDEPEND="
gnome-base/gsettings-desktop-schemas
- sys-devel/gettext
- sys-devel/make
-"
+ sys-devel/gettext"
PATCHES=(
"${FILESDIR}"/${PN}-3.3.2-paths.patch
diff --git a/x11-terms/guake/guake-9999.ebuild b/x11-terms/guake/guake-9999.ebuild
index 7d3392905944..51743bb8c8f5 100644
--- a/x11-terms/guake/guake-9999.ebuild
+++ b/x11-terms/guake/guake-9999.ebuild
@@ -1,21 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 git-r3 gnome2-utils xdg-utils
+inherit distutils-r1 gnome2-utils xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Guake/guake.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
DESCRIPTION="Drop-down terminal for GNOME"
HOMEPAGE="
https://github.com/Guake/guake/
https://pypi.org/project/guake/"
-EGIT_REPO_URI="https://github.com/Guake/guake.git"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="utempter"
RDEPEND="
@@ -30,14 +37,11 @@ RDEPEND="
x11-libs/libnotify[introspection]
x11-libs/libwnck:3[introspection]
x11-libs/vte:2.91[introspection]
- utempter? ( sys-libs/libutempter )
-"
-DEPEND="
- ${RDEPEND}
+ utempter? ( sys-libs/libutempter )"
+DEPEND="${RDEPEND}"
+BDEPEND="
gnome-base/gsettings-desktop-schemas
- sys-devel/gettext
- sys-devel/make
-"
+ sys-devel/gettext"
PATCHES=(
"${FILESDIR}"/${PN}-3.3.2-paths.patch