summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-11 23:54:52 +0000
committerSam James <sam@gentoo.org>2022-03-11 23:54:52 +0000
commite9906938a6a90284b1ac83f8d171d94dd91534b8 (patch)
treeb23141c88f232adcbaa39b90b72a6fb2d22cf42c /x11-terms
parentwww-client/firefox: Stabilize 91.7.0 arm64, #834827 (diff)
downloadgentoo-e9906938a6a90284b1ac83f8d171d94dd91534b8.tar.gz
gentoo-e9906938a6a90284b1ac83f8d171d94dd91534b8.tar.bz2
gentoo-e9906938a6a90284b1ac83f8d171d94dd91534b8.zip
x11-terms/xterm: add 372
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/xterm/Manifest1
-rw-r--r--x11-terms/xterm/xterm-372.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/x11-terms/xterm/Manifest b/x11-terms/xterm/Manifest
index 236b98b98dfd..e8fb708322f2 100644
--- a/x11-terms/xterm/Manifest
+++ b/x11-terms/xterm/Manifest
@@ -1,3 +1,4 @@
DIST xterm-367.tgz 1448562 BLAKE2B 29b38ba3b48c843ecbf22d209a05afb4e9a6d52cf8f14efa18ed5dd02b26cc11c107bfb17260cb62f68fc318cb08e5147b5f12e8779ca63151c7b712ada60b7e SHA512 86fd6ed4e4aa0201349edd67d8bf00d3b93a19640307372011f9bdcd26fdb453267d1ab092a0639902e419b00c175d793b196884b6e65e546650e1b83a4461c4
DIST xterm-370.tgz 1500208 BLAKE2B 973cda2511e761be64332746f004ed9ea716c8f5b7065cef2ef60d789e6186138b671920f23135b5c66d3226ce17c1d195db456350c94f5f0973e29610896b1a SHA512 24f1836c4f5aec175c45db77e9bc829b45ee2c93cf12c20252b22bee470392ef0637cfbbb6e90074b1c038ac023f74a4fb713bbd4abf2b5b86d064667caf38dd
DIST xterm-371.tgz 1507938 BLAKE2B 4ae16885bc07e7a0feb9aae29ef724f45e1170ba1eb7660c000df9a3f903c73063569d366383e7c30546480675b3fcd6513bb824ee3a5ee05155739e858360c5 SHA512 024c2cd8ab5a9da6585999907974a917497f693a0fb8cf4519c41c7e75ef2bfcc146c7078129590a836a322f7e59a550ad741b55dcbe98be6ee7988ccebe8903
+DIST xterm-372.tgz 1507107 BLAKE2B 256b99b13512740086203c4c05685cd170356118e11029a01d30b32f69c1fc5088efa0dabc955d8a24acf36f3e061faf7af9866c2302a4ac45405b97455384a0 SHA512 f65fee6227ca27be85569ec06f3701a6114489e036975d0fe37f3c71d7598d1b06c8689cfbda593a98418eec1417bd60b33e3978752b255989cfa0bb4ce332bf
diff --git a/x11-terms/xterm/xterm-372.ebuild b/x11-terms/xterm/xterm-372.ebuild
new file mode 100644
index 000000000000..9a982a2d7cbb
--- /dev/null
+++ b/x11-terms/xterm/xterm-372.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop flag-o-matic toolchain-funcs
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="https://invisible-island.net/xterm/"
+SRC_URI="ftp://ftp.invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+openpty sixel toolbar truetype unicode Xaw3d xinerama"
+
+BDEPEND="virtual/pkgconfig
+ x11-base/xorg-proto"
+DEPEND="
+ kernel_linux? ( sys-libs/libutempter )
+ media-libs/fontconfig:1.0
+ >=sys-libs/ncurses-5.7-r7:0=
+ x11-apps/xmessage
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}
+ media-fonts/font-misc-misc
+ x11-apps/rgb"
+
+DOCS=( README{,.i18n} ctlseqs.txt )
+
+src_configure() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+
+ # bug #454736
+ # Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
+ # something sane like pkg-config or ncurses5-config and stops guessing libs
+ # Everything gets linked against ncurses anyways, so don't shout
+ append-libs $($(tc-getPKG_CONFIG) --libs ncurses)
+
+ local myeconfargs=(
+ --disable-full-tgetent
+ --disable-imake
+ --disable-setgid
+ --disable-setuid
+ --enable-256-color
+ --enable-broken-osc
+ --enable-broken-st
+ --enable-dabbrev
+ --enable-exec-xterm
+ --enable-i18n
+ --enable-load-vt-fonts
+ --enable-logging
+ --enable-screen-dumps
+ --enable-warnings
+ --enable-wide-chars
+ --libdir="${EPREFIX}"/etc
+ --with-app-defaults="${DEFAULTS_DIR}"
+ --with-utempter
+ --with-x
+ $(use_enable openpty)
+ $(use_enable sixel sixel-graphics)
+ $(use_enable toolbar)
+ $(use_enable truetype freetype)
+ $(use_enable unicode luit)
+ $(use_enable unicode mini-luit)
+ $(use_with Xaw3d)
+ $(use_with xinerama)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc xterm.log.html
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e 's:blue2$:blue:' "${D}${DEFAULTS_DIR}"/XTerm-color || die
+}