summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-01-05 14:23:25 +0100
committerPacho Ramos <pacho@gentoo.org>2019-01-05 14:23:25 +0100
commit059caf9e8580367222ff50421195daef71464319 (patch)
tree0b9a2f3ff2be3de0df6fa671c1059ed4101f8577 /x11-themes/QGnomePlatform/QGnomePlatform-0.5.ebuild
parentmedia-tv/mythtv: libmp3lame is needed (diff)
downloadgentoo-059caf9e8580367222ff50421195daef71464319.tar.gz
gentoo-059caf9e8580367222ff50421195daef71464319.tar.bz2
gentoo-059caf9e8580367222ff50421195daef71464319.zip
x11-themes/QGnomePlatform: Bump to 0.5
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes/QGnomePlatform/QGnomePlatform-0.5.ebuild')
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.5.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.5.ebuild
new file mode 100644
index 000000000000..43850c02741e
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-5.6:5=
+ x11-libs/gtk+:3[X]
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ INSTALL_ROOT="${D}" default
+}