summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-10-02 10:00:33 +0200
committerPacho Ramos <pacho@gentoo.org>2022-10-02 10:00:33 +0200
commit91bafb832189e185d36c3d512f6781ff3a969414 (patch)
tree633be07e1a618914f0d6b2a11d0c28cce189ae00 /x11-themes/QGnomePlatform
parentx11-themes/adwaita-qt: drop 1.3.1, 1.4.0 (diff)
downloadgentoo-91bafb832189e185d36c3d512f6781ff3a969414.tar.gz
gentoo-91bafb832189e185d36c3d512f6781ff3a969414.tar.bz2
gentoo-91bafb832189e185d36c3d512f6781ff3a969414.zip
x11-themes/QGnomePlatform: add 0.9.0
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes/QGnomePlatform')
-rw-r--r--x11-themes/QGnomePlatform/Manifest1
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.9.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/Manifest b/x11-themes/QGnomePlatform/Manifest
index fb5fcf58d277..b4291fecfc0a 100644
--- a/x11-themes/QGnomePlatform/Manifest
+++ b/x11-themes/QGnomePlatform/Manifest
@@ -1,2 +1,3 @@
DIST QGnomePlatform-0.8.3.tar.gz 38556 BLAKE2B 34348bdcd0e5e8d068ba660fa0487e20a495c6584193f69dcd528c892b0259206899de33e833c276ee6b0f1dbb2076b154cdde762f90f5127e9a1156fb8c8627 SHA512 64cba8e01ccb960669f6d9150cfb0f0b03e2371fffb6429fe7b5b6385ab825de6285a98ec27988bf87bb1ce8d61279b0a1fc85a01762aac4b57800f558fa2ff7
DIST QGnomePlatform-0.8.4.tar.gz 38602 BLAKE2B 19f33ca6fbf43fd5bbd53fec38187802bf0c0d48c4018cff9ae7252e3cca8c8abe27b0aaee54728ad4c232c97efda2163c5a1c1347b1d446f8fa955a0e7709c6 SHA512 e5bb5feae401bca145c4b7a4fc18f5a589e2acba20b9ce7d04a7dd1b1734741daf210ff8fba5e03ef5e4ad07efd274a1279e61b359f319b52e3b9bc4d49f9142
+DIST QGnomePlatform-0.9.0.tar.gz 43828 BLAKE2B aa4d1d9269c444d95e7d25e0e0206a63adf0a1be8658624b61d5e5fe55d3714e38a66ecbb6ea19ebf0cc9ee1ed4fb5cf4f29a84e7052c1c2475deca395794cd3 SHA512 7671b0659959ede79e47a821481a14ed861418f364d3d0b48789b1edfcf3b84f2aa658e3afce95730a841fdb018ebad38474a83268bd43b1ccfb653ef7e314aa
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.9.0.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.9.0.ebuild
new file mode 100644
index 000000000000..935a1bad9776
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtdbus:5=
+ >=dev-qt/qtwidgets-5.15.2:5=
+ dev-qt/qtwayland:5=
+ dev-qt/qtx11extras:5=
+ gnome-base/gsettings-desktop-schemas
+ sys-apps/xdg-desktop-portal
+ x11-libs/gtk+:3[X]
+ >=x11-themes/adwaita-qt-1.4.2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT6=false
+ )
+ cmake_src_configure
+}