summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-28 22:46:27 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-29 00:57:50 +0100
commit6b1d687ad0f6aa23d8898707eb6ad3ab36050bf0 (patch)
tree70f12d79b668b443333d4c7532afecb324fdf967 /x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.30.1.ebuild
parentsys-apps/baobab: 3.26.1 → 3.30.0 (diff)
downloadgentoo-6b1d687ad0f6aa23d8898707eb6ad3ab36050bf0.tar.gz
gentoo-6b1d687ad0f6aa23d8898707eb6ad3ab36050bf0.tar.bz2
gentoo-6b1d687ad0f6aa23d8898707eb6ad3ab36050bf0.zip
x11-themes/adwaita-icon-theme: 3.26.1 → 3.30.1
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.30.1.ebuild')
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.30.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.30.1.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.30.1.ebuild
new file mode 100644
index 000000000000..685e2ae981dc
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.30.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome2
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="https://git.gnome.org/browse/adwaita-icon-theme/"
+
+SRC_URI="${SRC_URI}
+ branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+"
+LICENSE="
+ || ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-BY-SA-4.0 )
+"
+SLOT="0"
+IUSE="branding"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
+# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
+COMMON_DEPEND="
+ >=x11-themes/hicolor-icon-theme-0.10
+ gnome-base/librsvg:2
+"
+RDEPEND="${COMMON_DEPEND}
+ !<x11-themes/gnome-themes-standard-3.14
+"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/gtk+:3
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/Adwaita/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ # Install cursors in the right place used in Gentoo
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i "${S}"/Makefile.am \
+ -i "${S}"/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
+}