summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-07-31 09:52:13 +0200
committerPacho Ramos <pacho@gentoo.org>2019-07-31 09:52:13 +0200
commit9cbd01c3f756d959157cf13b8d39a48c2753878a (patch)
tree41bba9722f3c469d2960d319cf07378c5ca04d44 /x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild
parentgnome-extra/gnome-shell-extension-dash-to-panel: Bump to v20 (diff)
downloadgentoo-9cbd01c3f756d959157cf13b8d39a48c2753878a.tar.gz
gentoo-9cbd01c3f756d959157cf13b8d39a48c2753878a.tar.bz2
gentoo-9cbd01c3f756d959157cf13b8d39a48c2753878a.zip
x11-themes/adwaita-qt: Bump to 1.1.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild')
-rw-r--r--x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild b/x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild
new file mode 100644
index 000000000000..5e4cc7643b77
--- /dev/null
+++ b/x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils
+
+DESCRIPTION="A style to bend Qt applications to look like they belong into GNOME Shell"
+HOMEPAGE="https://github.com/FedoraQt/adwaita-qt"
+SRC_URI="https://github.com/FedoraQt/${PN}/archive/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+
+IUSE="gnome"
+
+RDEPEND="
+ gnome? ( x11-themes/QGnomePlatform )
+ dev-qt/qtwidgets:5
+ dev-qt/qtdbus:5
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ BUILD_DIR="${WORKDIR}/${PN}_qt5"
+ local mycmakeargs=( -DUSE_QT4=OFF )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ local _d
+ for _d in "${WORKDIR}"/${PN}_qt*; do
+ cmake-utils_src_compile -C "${_d}"
+ done
+}
+
+src_install() {
+ local _d
+ for _d in "${WORKDIR}"/${PN}_qt*; do
+ cmake-utils_src_install -C "${_d}"
+ done
+}