summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/fvwm-crystal/fvwm-crystal-3.2.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/fvwm-crystal/fvwm-crystal-3.2.3.ebuild')
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.2.3.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.2.3.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.2.3.ebuild
new file mode 100644
index 000000000000..e65342e28c80
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.2.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-r1
+
+DESCRIPTION="Configurable and full featured FVWM theme, with lots of transparency and freedesktop compatible menu"
+HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-wm/fvwm-2.6.5[png]
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
+ || ( x11-misc/hsetroot media-gfx/feh )
+ sys-apps/sed
+ sys-devel/bc
+ virtual/awk
+ x11-apps/xwd"
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" \
+ prefix="/usr" \
+ install
+
+ python_replicate_script \
+ "${D}/usr/bin/${PN}".{apps,wallpaper} \
+ "${D}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
+}
+
+pkg_postinst() {
+ einfo
+ einfo "After installation, execute following commands:"
+ einfo " $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xresources ~/.Xresources"
+ einfo " $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xsession ~/.xinitrc"
+ einfo
+ einfo "Many applications can extend functionality of fvwm-crystal."
+ einfo "They are listed in ${ROOT}usr/share/doc/${PF}/INSTALL.gz."
+ einfo
+ einfo "Some icons fixes was committed recently."
+ einfo "To archive the same fixes on your private icon files,"
+ einfo "please read ${ROOT}usr/share/doc/${PF}/INSTALL.gz."
+ einfo "This will fix the libpng warnings at stderr."
+ einfo
+ einfo "The color themes was updated to Fvwm InfoStore."
+ einfo "To know how to update your custom color themes, please run"
+ einfo " ${ROOT}usr/share/${PN}/addons/convert_colorsets"
+ einfo ""
+}