summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-26 21:49:37 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-26 22:33:34 +0200
commit189142a2df1581dceeed3077214909814cbc51fb (patch)
tree0dcf844f295a8e74695762a44e8758ea7e565373 /x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r1.ebuild
parentnet-misc/openssh: Add KillMode=process to sshd.service (diff)
downloadgentoo-189142a2df1581dceeed3077214909814cbc51fb.tar.gz
gentoo-189142a2df1581dceeed3077214909814cbc51fb.tar.bz2
gentoo-189142a2df1581dceeed3077214909814cbc51fb.zip
x11-themes/gentoo-xcursors: add missing dep
Bug: https://bugs.gentoo.org/758236 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r1.ebuild')
-rw-r--r--x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r1.ebuild b/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..f13b85327b3b
--- /dev/null
+++ b/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A high quality set of animated mouse cursors"
+HOMEPAGE="https://schlomp.space/tastytea/gentoo-xcursors"
+SRC_URI="https://schlomp.space/tastytea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
+
+RDEPEND="x11-libs/libXcursor"
+
+src_install() {
+ insinto /usr/share/cursors/xorg-x11
+ doins -r cursors/*
+}
+
+pkg_postinst() {
+ einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ einfo "and add the following line (for example):"
+ einfo "Xcursor.theme: gentoo"
+ einfo ""
+ einfo "You can change the size by adding a line like:"
+ einfo "Xcursor.size: 48"
+ einfo ""
+ einfo "Also, to globally use this set of mouse cursors edit the file:"
+ einfo " /usr/local/share/cursors/xorg-x11/default/index.theme"
+ einfo "and change the line:"
+ einfo " Inherits=[current setting]"
+ einfo "to (for example)"
+ einfo " Inherits=gentoo"
+ einfo ""
+ einfo "Note this will be overruled by a user's ~/.Xdefaults file."
+ einfo ""
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn ""
+ ewarn "the Device section of your xorg.conf file:"
+ ewarn " Option \"HWCursor\" \"false\""
+ einfo ""
+ einfo "The three sets installed are gentoo, gentoo-silver and gentoo-blue."
+}