summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-05-21 04:07:18 +0200
committerMatt Turner <mattst88@gentoo.org>2020-05-21 19:40:13 -0700
commit0f6a2eb6dde3a37fd009b189f81557b17d073967 (patch)
tree1b6f151335ea28e1895422b1f4d8a2558e0eae8e /x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2.ebuild
parentdev-python/python-xmlsec-1.3.8: Version bump (diff)
downloadgentoo-0f6a2eb6dde3a37fd009b189f81557b17d073967.tar.gz
gentoo-0f6a2eb6dde3a37fd009b189f81557b17d073967.tar.bz2
gentoo-0f6a2eb6dde3a37fd009b189f81557b17d073967.zip
x11-themes/gentoo-xcursors: Version bump 0.3.2.
Closes: https://bugs.gentoo.org/724232 Closes: https://github.com/gentoo/gentoo/pull/15899 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2.ebuild')
-rw-r--r--x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2.ebuild b/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2.ebuild
new file mode 100644
index 000000000000..f9fabb570695
--- /dev/null
+++ b/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2005-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A high quality set of animated mouse cursors"
+HOMEPAGE="https://schlomp.space/tastytea/gentoo-xcursors"
+SRC_URI="https://schlomp.space/tastytea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/gentoo-xcursors"
+
+src_install() {
+ insinto /usr/share/cursors/xorg-x11
+ doins -r cursors/*
+}
+
+pkg_postinst() {
+ einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ einfo "and add the following line (for example):"
+ einfo "Xcursor.theme: gentoo"
+ einfo ""
+ einfo "You can change the size by adding a line like:"
+ einfo "Xcursor.size: 48"
+ einfo ""
+ einfo "Also, to globally use this set of mouse cursors edit the file:"
+ einfo " /usr/local/share/cursors/xorg-x11/default/index.theme"
+ einfo "and change the line:"
+ einfo " Inherits=[current setting]"
+ einfo "to (for example)"
+ einfo " Inherits=gentoo"
+ einfo ""
+ einfo "Note this will be overruled by a user's ~/.Xdefaults file."
+ einfo ""
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn ""
+ ewarn "the Device section of your xorg.conf file:"
+ ewarn " Option \"HWCursor\" \"false\""
+ einfo ""
+ einfo "The three sets installed are gentoo, gentoo-silver and gentoo-blue."
+}