summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r2.ebuild')
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r2.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r2.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r2.ebuild
new file mode 100644
index 000000000000..d77a67912f79
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 multilib-minimal
+
+DESCRIPTION="Standard Themes for GNOME Applications"
+HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gtk"
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ gnome-base/librsvg:2[${MULTILIB_USEDEP}]
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ gtk? (
+ >=x11-libs/gtk+-2.24.15:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.12:3[${MULTILIB_USEDEP}] )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# gnome-themes{,-extras} are OBSOLETE for GNOME 3
+# http://comments.gmane.org/gmane.comp.gnome.desktop/44130
+# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
+# their default background image
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-3.4
+ !<x11-themes/gnome-themes-2.32.1-r1
+"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=746920
+ epatch "${FILESDIR}/${PN}-3.14.2.3-srcdir.patch"
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ # The icon cache needs to be generated in pkg_postinst()
+ ECONF_SOURCE="${S}" \
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable gtk gtk2-engine) \
+ $(use_enable gtk gtk3-engine) \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+emake_engines_only() {
+ pushd themes/Adwaita/gtk-2.0 > /dev/null || die
+ if [[ $1 = install ]]; then
+ emake DESTDIR="${D}" install-engineLTLIBRARIES
+ else
+ emake libadwaita.la
+ fi
+ popd > /dev/null
+}
+
+multilib_src_compile() {
+ # processing >3500 icons is slow on old hard drives, do it only for native ABI
+ if multilib_is_native_abi; then
+ gnome2_src_compile
+ elif use gtk; then
+ emake_engines_only
+ fi
+}
+
+multilib_src_install() {
+ # processing >3500 icons is slow on old hard drives, do it only for native ABI
+ if multilib_is_native_abi; then
+ gnome2_src_install
+ elif use gtk; then
+ emake_engines_only install
+ prune_libtool_files --modules
+ fi
+}