summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-08-22 11:56:19 -0500
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-29 13:41:07 +0100
commit6806329e83902090dc21c135b8bcfd86a3b43ce9 (patch)
treeee0c5261e8d2afeb6ffcfa26309db242aa7fc767 /x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.3-r1.ebuild
parentprofiles: package.mask cleanup (diff)
downloadgentoo-6806329e83902090dc21c135b8bcfd86a3b43ce9.tar.gz
gentoo-6806329e83902090dc21c135b8bcfd86a3b43ce9.tar.bz2
gentoo-6806329e83902090dc21c135b8bcfd86a3b43ce9.zip
x11-themes/gnome-themes-standard: add missing gnome2-utils
Package-Manager: Portage-2.3.48, Repoman-2.3.10 Signed-off-by: Marty E. Plummer <hanetzer@startmail.com> Closes: https://github.com/gentoo/gentoo/pull/9667 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.3-r1.ebuild')
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.3-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.3-r1.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.3-r1.ebuild
new file mode 100644
index 000000000000..ebc9862982b7
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.3-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome.org gnome2-utils
+
+DESCRIPTION="Standard Themes for GNOME Applications"
+HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
+# their default background image
+RDEPEND="
+ >=gnome-base/gsettings-desktop-schemas-3.4
+"
+DEPEND="
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://bugzilla.gnome.org/show_bug.cgi?id=746920
+ "${FILESDIR}"/${PN}-3.14.2.3-srcdir.patch
+ # Leave build of gtk+:2 engine to x11-themes/gtk-engines-adwaita
+ "${FILESDIR}"/${PN}-3.22.2-exclude-engine.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ --disable-gtk2-engine \
+ --disable-gtk3-engine \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}