summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-24 12:53:13 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-24 12:53:13 +0100
commit890702867e9e2c057e778ad5434d13f503f85923 (patch)
tree5b83b727b3dfc517a8813568195c91a1e71657a1 /x11-themes/gtk-engines-aurora/gtk-engines-aurora-1.5.1.ebuild
parentdev-scheme/guile-json: bump up to 3.3.0 (diff)
downloadgentoo-890702867e9e2c057e778ad5434d13f503f85923.tar.gz
gentoo-890702867e9e2c057e778ad5434d13f503f85923.tar.bz2
gentoo-890702867e9e2c057e778ad5434d13f503f85923.zip
x11-themes/gtk-engines-aurora: Port to EAPI 7
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-themes/gtk-engines-aurora/gtk-engines-aurora-1.5.1.ebuild')
-rw-r--r--x11-themes/gtk-engines-aurora/gtk-engines-aurora-1.5.1.ebuild38
1 files changed, 17 insertions, 21 deletions
diff --git a/x11-themes/gtk-engines-aurora/gtk-engines-aurora-1.5.1.ebuild b/x11-themes/gtk-engines-aurora/gtk-engines-aurora-1.5.1.ebuild
index 503ede706f1d..f85ed5696b88 100644
--- a/x11-themes/gtk-engines-aurora/gtk-engines-aurora-1.5.1.ebuild
+++ b/x11-themes/gtk-engines-aurora/gtk-engines-aurora-1.5.1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils versionator
+EAPI=7
-MY_MAJ=$(get_version_component_range 1-2)
+MY_MAJ=$(ver_cut 1-2)
DESCRIPTION="Aurora GTK+ 2.x Theme Engine"
HOMEPAGE="http://www.gnome-look.org/content/show.php?content=56438"
@@ -13,24 +12,21 @@ SRC_URI="http://gnome-look.org/CONTENT/content-files/56438-aurora-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE=""
-RDEPEND=">=dev-libs/glib-2
- >=x11-libs/gtk+-2.10:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPED="virtual/pkgconfig"
-S=${WORKDIR}/aurora-${MY_MAJ}
+S="${WORKDIR}/aurora-${MY_MAJ}"
+
+PATCHES=( "${FILESDIR}"/${P}-glib-2.31.patch )
src_unpack() {
unpack ${A}
- cd "${WORKDIR}"
- tar -xzf aurora-gtk-engine-${MY_MAJ}.tar.gz || die
- tar -xjf Aurora.tar.bz2 || die
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-glib-2.31.patch
+ unpack ./aurora-gtk-engine-${MY_MAJ}.tar.gz
+ unpack ./Aurora.tar.bz2
}
src_configure() {
@@ -38,11 +34,11 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog NEWS README
+ default
insinto /usr/share/themes/Aurora
- doins -r ../Aurora/*
+ doins -r ../Aurora/.
- find "${ED}"/usr -name '*.la' -type f -exec rm -f {} +
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}