summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-04-30 07:29:49 -0700
committerLars Wendler <polynomial-c@gentoo.org>2021-04-30 18:16:42 +0200
commitf22efd7a1c09380d7312ac954a0f0cc470817d45 (patch)
treee1e5fee11753daaee7f39a9126fb5ecd40a393a1 /x11-themes/gtk-engines-candido/files/gtk-engines-candido-0.9.1-libm.patch
parentgames-puzzle/gnome-sudoku: Version bump to 40.1 (diff)
downloadgentoo-f22efd7a1c09380d7312ac954a0f0cc470817d45.tar.gz
gentoo-f22efd7a1c09380d7312ac954a0f0cc470817d45.tar.bz2
gentoo-f22efd7a1c09380d7312ac954a0f0cc470817d45.zip
x11-themes/gtk-engines-candidio: Fix for slibtool
Thanks-to: orbea <orbea@riseup.net> Closes: https://bugs.gentoo.org/779478 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-themes/gtk-engines-candido/files/gtk-engines-candido-0.9.1-libm.patch')
-rw-r--r--x11-themes/gtk-engines-candido/files/gtk-engines-candido-0.9.1-libm.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-candido/files/gtk-engines-candido-0.9.1-libm.patch b/x11-themes/gtk-engines-candido/files/gtk-engines-candido-0.9.1-libm.patch
new file mode 100644
index 000000000000..a2d87d35d96f
--- /dev/null
+++ b/x11-themes/gtk-engines-candido/files/gtk-engines-candido-0.9.1-libm.patch
@@ -0,0 +1,31 @@
+commit 11de11a1cfa840545dd8fd9b41937445c6107f86
+Author: orbea <orbea@riseup.net>
+Date: Wed Mar 31 05:11:07 2021 -0700
+
+ build: Fix undefined reference for libm.
+
+diff --git a/Makefile.am b/Makefile.am
+index 62fd2e3..78ccc65 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,5 +22,4 @@ libcandido_la_SOURCES = \
+ ./src/config.h
+
+ libcandido_la_LDFLAGS = -module -avoid-version -no-undefined
+-libcandido_la_LIBADD = $(GTK_LIBS)
+-
++libcandido_la_LIBADD = $(GTK_LIBS) $(LIBM)
+diff --git a/configure.ac b/configure.ac
+index 8e261af..8570101 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -27,6 +27,9 @@ PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.8.0,,
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+
++AC_CHECK_LIBM
++AC_SUBST([LIBM])
++
+ GTK_VERSION=`$PKG_CONFIG --variable=gtk_binary_version gtk+-2.0`
+ AC_SUBST(GTK_VERSION)
+