summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-08 17:16:57 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-08 17:16:57 +0100
commit396eef6d4ceadd1c06105e8150f9edad754ed1b2 (patch)
tree77cb1ab3e68ff337306503a1fb636a4979bfbb29 /x11-themes/gtk-engines-rezlooks
parentx11-plugins/pidgin-gpg: Remove old (diff)
downloadgentoo-396eef6d4ceadd1c06105e8150f9edad754ed1b2.tar.gz
gentoo-396eef6d4ceadd1c06105e8150f9edad754ed1b2.tar.bz2
gentoo-396eef6d4ceadd1c06105e8150f9edad754ed1b2.zip
x11-themes/gtk-engines-rezlooks: Proper EAPI 7 port
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-themes/gtk-engines-rezlooks')
-rw-r--r--x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6-r1.ebuild25
1 files changed, 11 insertions, 14 deletions
diff --git a/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6-r1.ebuild b/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6-r1.ebuild
index 445122e83828..4886633ce530 100644
--- a/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6-r1.ebuild
+++ b/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6-r1.ebuild
@@ -1,28 +1,25 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools
DESCRIPTION="Rezlooks GTK+ Engine"
HOMEPAGE="https://www.gnome-look.org/content/show.php?content=39179"
-SRC_URI="https://www.gnome-look.org/content/files/39179-rezlooks-0.6.tar.gz"
+SRC_URI="https://www.gnome-look.org/content/files/39179-rezlooks-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-RDEPEND="
- >=x11-libs/gtk+-2.8:2
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-0.6-glib-single-include.patch
-)
-S=${WORKDIR}/rezlooks-${PV}
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/rezlooks-${PV}
+
+PATCHES=( "${FILESDIR}"/${PN}-0.6-glib-single-include.patch )
src_prepare() {
default
@@ -41,5 +38,5 @@ src_configure() {
src_install() {
default
- find "${D}" -name '*.la' -exec rm -f {} + || die
+ find "${D}" -name '*.la' -delete || die
}