summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-04-30 07:35:33 -0700
committerLars Wendler <polynomial-c@gentoo.org>2021-04-30 18:16:43 +0200
commit09d9c2e82538203f16df9622dcb2a754f16e44e3 (patch)
treeb9c48cafc27e7c09e9436c83d521cc6a339923f2 /x11-themes/gtk-engines-ubuntulooks
parentx11-themes/gtk-engines-candidio: Fix for slibtool (diff)
downloadgentoo-09d9c2e82538203f16df9622dcb2a754f16e44e3.tar.gz
gentoo-09d9c2e82538203f16df9622dcb2a754f16e44e3.tar.bz2
gentoo-09d9c2e82538203f16df9622dcb2a754f16e44e3.zip
x11-themes/gtk-engines-ubuntulooks: Fix for slibtool
Thanks-to: orbea <orbea@riseup.net> Closes: https://bugs.gentoo.org/778218 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-themes/gtk-engines-ubuntulooks')
-rw-r--r--x11-themes/gtk-engines-ubuntulooks/files/gtk-engines-ubuntulooks-0.9.12-libm.patch31
-rw-r--r--x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild1
2 files changed, 32 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-ubuntulooks/files/gtk-engines-ubuntulooks-0.9.12-libm.patch b/x11-themes/gtk-engines-ubuntulooks/files/gtk-engines-ubuntulooks-0.9.12-libm.patch
new file mode 100644
index 000000000000..e25df1890bdc
--- /dev/null
+++ b/x11-themes/gtk-engines-ubuntulooks/files/gtk-engines-ubuntulooks-0.9.12-libm.patch
@@ -0,0 +1,31 @@
+commit cd04daa9777f613daa23b3dd6f8ae1f7bc270cf8
+Author: orbea <orbea@riseup.net>
+Date: Wed Mar 31 06:58:01 2021 -0700
+
+ build: Fix undefined references for libm.
+
+diff --git a/configure.ac b/configure.ac
+index 1cf7578..3e3ba4c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -21,6 +21,9 @@ disableval="y"
+
+ AC_ARG_ENABLE(animation, [ --enable-animation compile clearlooks with animation support], [animation=$disableval], [animation=$enableval])
+
++AC_CHECK_LIBM
++AC_SUBST([LIBM])
++
+ PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.8.0,,
+ AC_MSG_ERROR([GTK+-2.8 is required to compile gtk-engines]))
+
+diff --git a/engine/Makefile.am b/engine/Makefile.am
+index d98d0a0..d555e6e 100644
+--- a/engine/Makefile.am
++++ b/engine/Makefile.am
+@@ -22,5 +22,4 @@ libubuntulooks_la_SOURCES = \
+ ./src/config.h
+
+ libubuntulooks_la_LDFLAGS = -module -avoid-version -no-undefined
+-libubuntulooks_la_LIBADD = $(GTK_LIBS)
+-
++libubuntulooks_la_LIBADD = $(GTK_LIBS) $(LIBM)
diff --git a/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild b/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
index 350ba68380c8..e63da284e5fd 100644
--- a/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
+++ b/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
@@ -34,6 +34,7 @@ PATCHES=(
"${S}"/debian/patches/02_fix-firefox-buttons.patch
# https://bugs.gentoo.org/419395
"${FILESDIR}"/${P}-glib-2.31.patch
+ "${FILESDIR}"/${P}-libm.patch
)
src_prepare() {