summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-08 09:15:14 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-08 10:29:23 +0200
commitc3d73f231cd51f15ded9dc6cbca2fa31190d2017 (patch)
treef02a78eeca88bb7bcf0382a32db053aff903bc2b /x11-themes/gtk-engines-xfce
parentxfce-extra/xfce4-wavelan-plugin: fdo-mime->xdg-utils (diff)
downloadgentoo-c3d73f231cd51f15ded9dc6cbca2fa31190d2017.tar.gz
gentoo-c3d73f231cd51f15ded9dc6cbca2fa31190d2017.tar.bz2
gentoo-c3d73f231cd51f15ded9dc6cbca2fa31190d2017.zip
x11-themes/gtk-engines-xfce: Port to EAPI=6
Diffstat (limited to 'x11-themes/gtk-engines-xfce')
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r201.ebuild36
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r301.ebuild36
2 files changed, 72 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r201.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r201.ebuild
new file mode 100644
index 000000000000..87d432f8a438
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r201.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+MY_PN=gtk-xfce-engine
+inherit multilib-minimal
+
+DESCRIPTION="A port of Xfce engine to GTK+ 2.x"
+HOMEPAGE="https://git.xfce.org/xfce/gtk-xfce-engine/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+multilib_src_configure() {
+ local ECONF_SOURCE=${S}
+ local myconf=(
+ --enable-gtk2
+ --disable-gtk3
+ )
+ econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r301.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r301.ebuild
new file mode 100644
index 000000000000..784947e3a22a
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r301.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+MY_PN=gtk-xfce-engine
+inherit multilib-minimal
+
+DESCRIPTION="A port of Xfce engine to GTK+ 3.x"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.24[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.2:3[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+multilib_src_configure() {
+ local ECONF_SOURCE=${S}
+ local myconf=(
+ --disable-gtk2
+ --enable-gtk3
+ )
+ econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}