summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-02-19 23:03:38 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-19 23:03:38 +0100
commit4100afd11d63d75125c0fe408aad1b30cb2f322b (patch)
tree6e8aa0abb07dcdcbf579f97ba8c21a80d7dc4dc8 /x11-themes/iceicons/iceicons-0.10.0-r2.ebuild
parentx11-themes/gtk-engines-quartz: update EAPI 6 -> 8 (diff)
downloadgentoo-4100afd11d63d75125c0fe408aad1b30cb2f322b.tar.gz
gentoo-4100afd11d63d75125c0fe408aad1b30cb2f322b.tar.bz2
gentoo-4100afd11d63d75125c0fe408aad1b30cb2f322b.zip
x11-themes/iceicons: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-themes/iceicons/iceicons-0.10.0-r2.ebuild')
-rw-r--r--x11-themes/iceicons/iceicons-0.10.0-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/iceicons/iceicons-0.10.0-r2.ebuild b/x11-themes/iceicons/iceicons-0.10.0-r2.ebuild
new file mode 100644
index 000000000000..708b7b6b4d38
--- /dev/null
+++ b/x11-themes/iceicons/iceicons-0.10.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="IceWM Icons is a set of XPM 16x16, 32x32, and 48x48 XPM and PNG icons for IceWM"
+HOMEPAGE="http://sandbox.cz/~covex/icewm/iceicons/"
+SRC_URI="http://sandbox.cz/~covex/icewm/iceicons/${PN}-default-${PV}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+
+RDEPEND=">=x11-wm/icewm-1.2.6"
+DEPEND="${RDEPEND}"
+
+ICEICONSDIR="/usr/share/icewm/icons/iceicons"
+
+src_install() {
+ insinto "${ICEICONSDIR}"
+ doins -r icons/.
+
+ fowners -R root:0 "${ICEICONSDIR}"
+ fperms -R o-w "${ICEICONSDIR}"
+
+ dodoc CHANGELOG README TODO winoptions
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use new IceWm icons, add following"
+ einfo "into your IceWm preference file:"
+ einfo "IconPath=\"${ICEICONSDIR}:${ICEICONSDIR}/menuitems\""
+ einfo
+}
+
+pkg_postrm() {
+ einfo
+ einfo "Update your IceWm preference."
+ einfo
+}